summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD67
3 files changed, 50 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c37d24a8db0..24409d40e3f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yambar
pkgdesc = Modular status panel for X11 and Wayland, inspired by polybar
- pkgver = 1.6.2
+ pkgver = 1.10.0
pkgrel = 1
url = https://codeberg.org/dnkl/yambar
arch = x86_64
@@ -8,22 +8,27 @@ pkgbase = yambar
makedepends = git
makedepends = meson
makedepends = scdoc
- depends = alsa-lib
- depends = libmpdclient
+ makedepends = tllist
+ makedepends = xorgproto
+ depends = fcft
+ depends = libpulse
+ depends = libudev.so
depends = libxcb
- depends = xorgproto
depends = libyaml
- depends = systemd
- depends = fontconfig
+ depends = libpipewire-0.3.so
+ depends = pipewire
+ depends = pixman
depends = wayland
depends = wayland-protocols
depends = xcb-util
depends = xcb-util-cursor
- depends = xcb-util-errors
depends = xcb-util-wm
- depends = pixman
- provides = yambar
- source = yambar-1.6.2.tar.gz::https://codeberg.org/dnkl/yambar/archive/1.6.2.tar.gz
- sha256sums = cb0813d5f8ce72d536e5b0714c773fd2b3ea0cb5e22b020b9ec0e33645040d3c
+ optdepends = alsa-lib: ALSA module
+ optdepends = json-c: XKB module
+ optdepends = libmpdclient: MPD module
+ optdepends = xcb-util-errors: better X error messages
+ source = git+https://codeberg.org/dnkl/yambar.git?signed#commit=c4e094de3e531675bae9ff76d7e6f0dfdcaecae9
+ validpgpkeys = B19964FBBA09664CC81027ED5BBD4992C116573F
+ b2sums = SKIP
pkgname = yambar
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a49cf3ce5556..da5ef96b65cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,43 @@
-# Maintainer: Moritz Poldrack <moritz at poldrack dot dev>
+# Maintainer: éclairevoyant
+
pkgname=yambar
-pkgver=1.6.2
+pkgver=1.10.0
pkgrel=1
pkgdesc='Modular status panel for X11 and Wayland, inspired by polybar'
-arch=('x86_64')
-url='https://codeberg.org/dnkl/yambar'
-license=('MIT')
-depends=(
- 'alsa-lib'
- 'libmpdclient'
- 'libxcb'
- 'xorgproto'
- 'libyaml'
- 'systemd'
- 'fontconfig'
- wayland{,-protocols}
- xcb-util{,-cursor,-errors,-wm}
- 'pixman'
- )
-makedepends=(
- 'git'
- 'meson'
- 'scdoc'
- )
-provides=('yambar')
-source=("${pkgname}-${pkgver}.tar.gz::https://codeberg.org/dnkl/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('cb0813d5f8ce72d536e5b0714c773fd2b3ea0cb5e22b020b9ec0e33645040d3c')
+arch=(x86_64)
+url="https://codeberg.org/dnkl/$pkgname"
+license=(MIT)
+depends=(fcft libpulse libudev.so libxcb libyaml libpipewire-0.3.so pipewire pixman
+ wayland wayland-protocols xcb-util xcb-util-cursor xcb-util-wm)
+optdepends=('alsa-lib: ALSA module'
+ 'json-c: XKB module'
+ 'libmpdclient: MPD module'
+ 'xcb-util-errors: better X error messages')
+makedepends=(git meson scdoc tllist xorgproto)
+source=("git+$url.git?signed#commit=c4e094de3e531675bae9ff76d7e6f0dfdcaecae9")
+b2sums=('SKIP')
+validpgpkeys=('B19964FBBA09664CC81027ED5BBD4992C116573F') # Daniel Eklöf (Git signing) <daniel@ekloef.se>
prepare() {
- cd yambar
-
- pushd subprojects
- git clone https://codeberg.org/dnkl/tllist.git
- git clone https://codeberg.org/dnkl/fcft.git
- popd
-
- mkdir -p bld/release && cd bld/release
- meson --buildtype=release --prefix=${pkgdir}/usr/ ../..
+ mkdir build
}
build() {
- cd "${srcdir}/yambar/bld/release";
+ cd build
+ meson ../$pkgname \
+ --buildtype=release \
+ --prefix=/usr \
+ --wrap-mode=nofallback \
+ -Db_lto=true \
+ -Dbackend-x11=enabled \
+ -Dbackend-wayland=enabled
ninja
}
package() {
- cd "${srcdir}/yambar/bld/release";
- ninja install
+ cd build
+ DESTDIR="$pkgdir" ninja install
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s '/usr/share/doc/yambar/LICENSE' "$pkgdir/usr/share/licenses/$pkgname/"
}