summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14eaf831fc5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yaml-cpp0.3
+ pkgdesc = YAML parser and emitter in C++, written around the YAML 1.2 spec
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = http://code.google.com/p/yaml-cpp/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ provides = yaml-cpp=0.3.0
+ conflicts = yaml-cpp
+ source = http://yaml-cpp.googlecode.com/files/yaml-cpp-0.3.0.tar.gz
+ md5sums = 9aa519205a543f9372bf4179071c8ac6
+
+pkgname = yaml-cpp0.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3179c4dc848e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Markus Martin <markus@archwyrm.net>
+pkgname=yaml-cpp0.3
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="YAML parser and emitter in C++, written around the YAML 1.2 spec"
+url="http://code.google.com/p/yaml-cpp/"
+arch=('i686' 'x86_64')
+license=('MIT')
+makedepends=('cmake')
+conflicts=("yaml-cpp")
+provides=("yaml-cpp=$pkgver")
+source=(http://yaml-cpp.googlecode.com/files/yaml-cpp-$pkgver.tar.gz)
+md5sums=('9aa519205a543f9372bf4179071c8ac6')
+
+build() {
+ cd "$srcdir"/yaml-cpp
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ cd "$srcdir"/yaml-cpp
+
+ make DESTDIR="$pkgdir" install
+}