summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--friend-function.patch37
3 files changed, 17 insertions, 58 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a286bacd2e2d..170b26991f9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Mar 6 22:45:02 UTC 2019
pkgbase = yap
pkgdesc = A high-performance Prolog compiler
- pkgver = 6.2.2
- pkgrel = 5
- url = http://www.dcc.fc.up.pt/~vsc/Yap/
+ pkgver = 6.3.3
+ pkgrel = 1
+ url = http://www.dcc.fc.up.pt/~vsc/yap/
arch = i686
arch = x86_64
license = PerlArtistic
depends = gmp
depends = unixodbc
depends = libmariadbclient
- source = http://www.dcc.fc.up.pt/~vsc/Yap/yap-6.2.2.tar.gz
- source = friend-function.patch
- md5sums = 95eaa54978e4811ff6e504e7dca9e835
- md5sums = 5b5884a62e8cd9482408565576b872f8
+ source = https://github.com/vscosta/yap-6.3/archive/yap-6.3.3.tar.gz
+ md5sums = 6d9d2e5617f53b077c8f7da0ada2731b
pkgname = yap
diff --git a/PKGBUILD b/PKGBUILD
index 7d79b91473c4..a3cfecc0fe44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,29 @@
-# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Leonidas <marek@xivilization.net>
pkgname=yap
-pkgver=6.2.2
-pkgrel=5
+pkgver=6.3.3
+pkgrel=1
pkgdesc='A high-performance Prolog compiler'
-url='http://www.dcc.fc.up.pt/~vsc/Yap/'
+url='http://www.dcc.fc.up.pt/~vsc/yap/'
license=('PerlArtistic')
arch=('i686' 'x86_64')
depends=('gmp' 'unixodbc' 'libmariadbclient')
#makedepends=('texi2html' 'texinfo' 'jdk7-openjdk' 'texlive-plainextra')
#optdepends=('java-runtime-headless: Java Interface Library JPL')
-source=("http://www.dcc.fc.up.pt/~vsc/Yap/${pkgname}-${pkgver}.tar.gz"
- "friend-function.patch")
-md5sums=('95eaa54978e4811ff6e504e7dca9e835'
- '5b5884a62e8cd9482408565576b872f8')
+#source=("http://www.dcc.fc.up.pt/~vsc/yap/${pkgname}-${pkgver}.tar.gz")
+source=("https://github.com/vscosta/yap-6.3/archive/yap-$pkgver.tar.gz")
+md5sums=('6d9d2e5617f53b077c8f7da0ada2731b')
# issues building java bindings and info pages?
# I leave those up to you to fix, dear reader
-# gcc 5 patch
-# http://pkgs.fedoraproject.org/cgit/yap.git/plain/yap-6.2.2-Friend-function-template-defined-in-a-class-cannot-b.patch
-
build() {
- cd ${pkgname}-${pkgver}
+ cd "yap-6.3-yap-$pkgver"
- patch -p1 -i ../friend-function.patch
+ #patch -p1 -i ../friend-function.patch
+ export CPPFLAGS+=" -fpermissive"
./configure \
--prefix=/usr \
--enable-threads \
@@ -42,7 +38,7 @@ build() {
}
package() {
- cd ${pkgname}-${pkgver}
+ cd "yap-6.3-yap-$pkgver"
make DESTDIR="${pkgdir}" install
#make DESTDIR="${pkgdir}" install_docs
diff --git a/friend-function.patch b/friend-function.patch
deleted file mode 100644
index 4261ee1120aa..000000000000
--- a/friend-function.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/packages/swi-minisat2/C/Solver.C b/packages/swi-minisat2/C/Solver.C
-index 2de3e6d..1bcdbff 100644
---- a/packages/swi-minisat2/C/Solver.C
-+++ b/packages/swi-minisat2/C/Solver.C
-@@ -120,7 +120,7 @@ bool Solver::addClause(vec<Lit>& ps)
- uncheckedEnqueue(ps[0]);
- return ok = (propagate() == NULL);
- }else{
-- Clause* c = Clause_new(ps, false);
-+ Clause* c = Clause::Clause_new(ps, false);
- clauses.push(c);
- attachClause(*c);
- }
-@@ -599,7 +599,7 @@ lbool Solver::search(int nof_conflicts, int nof_learnts)
- if (learnt_clause.size() == 1){
- uncheckedEnqueue(learnt_clause[0]);
- }else{
-- Clause* c = Clause_new(learnt_clause, true);
-+ Clause* c = Clause::Clause_new(learnt_clause, true);
- learnts.push(c);
- attachClause(*c);
- claBumpActivity(*c);
-diff --git a/packages/swi-minisat2/C/SolverTypes.h b/packages/swi-minisat2/C/SolverTypes.h
-index 47e3023..919b60b 100644
---- a/packages/swi-minisat2/C/SolverTypes.h
-+++ b/packages/swi-minisat2/C/SolverTypes.h
-@@ -119,7 +119,7 @@ public:
-
- // -- use this function instead:
- template<class V>
-- friend Clause* Clause_new(const V& ps, bool learnt = false) {
-+ static Clause* Clause_new(const V& ps, bool learnt = false) {
- assert(sizeof(Lit) == sizeof(uint32_t));
- assert(sizeof(float) == sizeof(uint32_t));
- void* mem = malloc(sizeof(Clause) + sizeof(uint32_t)*(ps.size()));
---
-1.9.3