summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d31b6c129644..8c2405517470 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yarock-qt5
pkgdesc = Qt Modern Music Player with collection browse based on cover art
pkgver = 1.1.4
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/yarock
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = yarock-qt5
depends = htmlcxx
depends = qt5-x11extras
depends = phonon-qt5
- depends = taglib
+ depends = taglib>=1.10
optdepends = mpv: alternative (working) engine
source = https://launchpad.net/yarock/1.x/1.1.4/+download/Yarock_1.1.4_source.tar.gz
source = phonon.patch
diff --git a/PKGBUILD b/PKGBUILD
index 006c65950cff..7015577477bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=yarock-qt5
pkgver=1.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Qt Modern Music Player with collection browse based on cover art"
arch=('i686' 'x86_64')
url="https://launchpad.net/yarock"
license=('GPL3')
makedepends=('cmake' 'mpv')
-depends=('htmlcxx' 'qt5-x11extras' 'phonon-qt5' 'taglib')
+depends=('htmlcxx' 'qt5-x11extras' 'phonon-qt5' 'taglib>=1.10')
optdepends=('mpv: alternative (working) engine')
source=("https://launchpad.net/yarock/1.x/${pkgver}/+download/Yarock_${pkgver}_source.tar.gz"
"phonon.patch")
@@ -28,7 +28,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DENABLE_QT5=1 \
- -DENABLE_MPV=ON
+ -DENABLE_MPV=ON \
+ -DTAGLIB_MIN_VERSION=1.10
make
}