summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d71a43f4742c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = yarpgen
+ pkgdesc = YARPGen (Yet Another Random Program Generator) for stress testing compilers
+ pkgver = v1.1.270.g0bfbe4f
+ pkgrel = 1
+ url = https://github.com/intel/yarpgen
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = gcc
+ depends = cmake
+ depends = make
+ source = yarpgen::git+https://github.com/intel/yarpgen.git
+ md5sums = SKIP
+
+pkgname = yarpgen
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0f0cd15dc88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Theodoros Theodoridis <theodoridisgr@gmail.com>
+pkgname=yarpgen
+pkgver=v1.1.270.g0bfbe4f
+pkgrel=1
+pkgdesc="YARPGen (Yet Another Random Program Generator) for stress testing compilers"
+arch=('x86_64')
+url="https://github.com/intel/yarpgen"
+license=('Apache')
+depends=('gcc' 'cmake' 'make') # Update these dependencies based on your needs.
+makedepends=('git')
+source=("$pkgname::git+https://github.com/intel/yarpgen.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the latest commit's hash as a version
+ git describe --always | sed 's/-/./g'
+}
+
+
+build() {
+ cd "$srcdir/$pkgname"
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ install -Dm755 yarpgen "$pkgdir/usr/bin/yarpgen"
+}
+