summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--0001-gnome-shell-fix-install-dir.patch58
-rw-r--r--PKGBUILD95
3 files changed, 199 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c93eac3d0b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = yaru-git
+ pkgdesc = Yaru default ubuntu theme
+ pkgver = 18.10.6.r7.g8b3f63d6
+ pkgrel = 1
+ url = https://github.com/ubuntu/yaru
+ arch = any
+ license = GPL3
+ makedepends = meson
+ makedepends = sassc
+ makedepends = git
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = git+https://github.com/ubuntu/yaru
+ source = 0001-gnome-shell-fix-install-dir.patch
+ sha256sums = SKIP
+ sha256sums = c84e9720c47fc86eaf89ebc647bb656b13a3e79aa0b01c46734c5db013e42bc5
+
+pkgname = yaru-sound-theme-git
+ pkgdesc = Yaru default ubuntu sound theme
+ provides = yaru-sound-theme
+ conflicts = yaru-sound-theme
+
+pkgname = yaru-gtk-theme-git
+ pkgdesc = Yaru default ubuntu gtk theme
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = gtk-engine-murrine
+ depends = gnome-themes-extra
+ provides = yaru-gtk-theme
+ conflicts = yaru-gtk-theme
+
+pkgname = yaru-gnome-shell-theme-git
+ pkgdesc = Yaru default ubuntu gnome shell theme
+ depends = gnome-shell
+ provides = yaru-gnome-shell-theme
+ conflicts = yaru-gnome-shell-theme
+
+pkgname = yaru-icon-theme-git
+ pkgdesc = Yaru default ubuntu icon theme
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = librsvg
+ provides = yaru-icon-theme
+ conflicts = yaru-icon-theme
+
diff --git a/0001-gnome-shell-fix-install-dir.patch b/0001-gnome-shell-fix-install-dir.patch
new file mode 100644
index 000000000000..5ff1efc7242b
--- /dev/null
+++ b/0001-gnome-shell-fix-install-dir.patch
@@ -0,0 +1,58 @@
+From d55e5ca2bd7544ceeb573cb24fe7cfe51a555c6b Mon Sep 17 00:00:00 2001
+From: Nicola Murino <nicola.murino@gmail.com>
+Date: Thu, 26 Jul 2018 14:44:20 +0200
+Subject: [PATCH] gnome-shell: fix install dir
+
+---
+ gnome-shell/meson.build | 2 +-
+ gnome-shell/src/meson.build | 2 +-
+ sessions/meson.build | 2 +-
+ sessions/meson/install-dock-override | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/gnome-shell/meson.build b/gnome-shell/meson.build
+index 7a1ce6dd..5de2ea79 100644
+--- a/gnome-shell/meson.build
++++ b/gnome-shell/meson.build
+@@ -1,3 +1,3 @@
+-gnomeshell_theme_dir = join_paths(get_option('datadir'), 'gnome-shell', 'theme')
++gnomeshell_theme_dir = join_paths(get_option('datadir'), 'themes')
+
+ subdir('src')
+diff --git a/gnome-shell/src/meson.build b/gnome-shell/src/meson.build
+index b0fb61a1..c4a59f73 100644
+--- a/gnome-shell/src/meson.build
++++ b/gnome-shell/src/meson.build
+@@ -1,5 +1,5 @@
+ # destination directory
+-install_dir = join_paths(gnomeshell_theme_dir, meson.project_name())
++install_dir = join_paths(gnomeshell_theme_dir, meson.project_name(), 'gnome-shell')
+
+ # generate .css files
+ theme_sources = files([
+diff --git a/sessions/meson.build b/sessions/meson.build
+index 4922cd2f..e07af06c 100644
+--- a/sessions/meson.build
++++ b/sessions/meson.build
+@@ -1,4 +1,4 @@
+-gnomeshell_mode_dir = join_paths(get_option('datadir'), 'gnome-shell', 'modes')
++gnomeshell_mode_dir = join_paths(get_option('datadir'), 'themes', meson.project_name(), 'gnome-shell', 'modes')
+
+ # NOTE: GNOME Shell only accept lowercase mode names.
+ replace_name = find_program('../build-helpers/replace-name')
+diff --git a/sessions/meson/install-dock-override b/sessions/meson/install-dock-override
+index d8a74050..b716ef41 100755
+--- a/sessions/meson/install-dock-override
++++ b/sessions/meson/install-dock-override
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+ set -eu
+
+-DOCK_DIR="${MESON_INSTALL_DESTDIR_PREFIX}/share/gnome-shell/extensions/ubuntu-dock@ubuntu.com"
++DOCK_DIR="${MESON_INSTALL_DESTDIR_PREFIX}/share/themes/Yaru/gnome-shell/extensions/ubuntu-dock@ubuntu.com"
+
+ mkdir -p "${DOCK_DIR}"
+ touch "${DOCK_DIR}/$1.css"
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e3b178f9b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: drakkan <nicola.murino at gmail dot com>
+
+pkgbase=yaru-git
+pkgname=(yaru-sound-theme-git
+ yaru-gtk-theme-git
+ yaru-gnome-shell-theme-git
+ yaru-icon-theme-git)
+pkgver=18.10.6.r7.g8b3f63d6
+pkgrel=1
+pkgdesc="Yaru default ubuntu theme"
+arch=(any)
+url="https://github.com/ubuntu/yaru"
+license=('GPL3')
+makedepends=('meson' 'sassc' 'git')
+options=('!strip' '!buildflags' 'staticlibs')
+source=("git+https://github.com/ubuntu/yaru"
+ "0001-gnome-shell-fix-install-dir.patch")
+sha256sums=('SKIP'
+ 'c84e9720c47fc86eaf89ebc647bb656b13a3e79aa0b01c46734c5db013e42bc5')
+
+pkgver() {
+ cd yaru
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd yaru
+ patch -Np1 < ../0001-gnome-shell-fix-install-dir.patch
+}
+
+build() {
+ arch-meson yaru build
+ ninja -C build
+}
+
+package_yaru-sound-theme-git() {
+ pkgdesc="Yaru default ubuntu sound theme"
+ provides=(yaru-sound-theme)
+ conflicts=(yaru-sound-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -r "$pkgdir/usr/share/glib-2.0"
+ rm -r "$pkgdir/usr/share/xsessions"
+ rm -r "$pkgdir/usr/share/wayland-sessions"
+ rm -r "$pkgdir/usr/share/icons"
+ rm -r "$pkgdir/usr/share/themes"
+}
+
+package_yaru-gtk-theme-git() {
+ pkgdesc="Yaru default ubuntu gtk theme"
+ depends=("gtk3" "gdk-pixbuf2" "gtk-engine-murrine" "gnome-themes-extra")
+ provides=(yaru-gtk-theme)
+ conflicts=(yaru-gtk-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -r "$pkgdir/usr/share/glib-2.0"
+ rm -r "$pkgdir/usr/share/xsessions"
+ rm -r "$pkgdir/usr/share/wayland-sessions"
+ rm -r "$pkgdir/usr/share/themes/Yaru/gnome-shell"
+ rm -r "$pkgdir/usr/share/icons"
+ rm -r "$pkgdir/usr/share/sounds"
+}
+
+package_yaru-gnome-shell-theme-git() {
+ pkgdesc="Yaru default ubuntu gnome shell theme"
+ depends=("gnome-shell")
+ provides=(yaru-gnome-shell-theme)
+ conflicts=(yaru-gnome-shell-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -r "$pkgdir/usr/share/glib-2.0"
+ rm -r "$pkgdir/usr/share/xsessions"
+ rm -r "$pkgdir/usr/share/wayland-sessions"
+ rm -r "$pkgdir/usr/share/icons"
+ rm -r "$pkgdir/usr/share/sounds"
+ rm -r "$pkgdir/usr/share/themes/Yaru/gtk-2.0"
+ rm -r "$pkgdir/usr/share/themes/Yaru/gtk-3.0"
+ rm -r "$pkgdir/usr/share/themes/Yaru/index.theme"
+ rm -r "$pkgdir/usr/share/themes/Yaru-dark"
+}
+
+package_yaru-icon-theme-git() {
+ pkgdesc="Yaru default ubuntu icon theme"
+ depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)
+ provides=(yaru-icon-theme)
+ conflicts=(yaru-icon-theme)
+
+ DESTDIR="$pkgdir" ninja -C build install
+ rm -r "$pkgdir/usr/share/glib-2.0"
+ rm -r "$pkgdir/usr/share/xsessions"
+ rm -r "$pkgdir/usr/share/wayland-sessions"
+ rm -r "$pkgdir/usr/share/sounds"
+ rm -r "$pkgdir/usr/share/themes"
+}