summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..926b45d6aff4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yasp-git
+ pkgdesc = A basic slot machine program for linux
+ pkgver = v1.0.2.r0.g2cfb594
+ pkgrel = 1
+ url = https://github.com/AsayuGit/YetAnotherSlotProject
+ arch = any
+ license = GPL2
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ provides = yasp
+ conflicts = yasp
+ source = git+https://github.com/AsayuGit/YetAnotherSlotProject.git
+ md5sums = SKIP
+
+pkgname = yasp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1253e4058481
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Asayu <asayu.yuki@gmail.com>
+pkgname=yasp-git
+_gitName="YetAnotherSlotProject"
+pkgver=v1.0.2.r0.g2cfb594
+pkgrel=1
+pkgdesc="A basic slot machine program for linux "
+arch=('any')
+url="https://github.com/AsayuGit/YetAnotherSlotProject"
+license=('GPL2')
+depends=(sdl2 sdl2_image sdl2_mixer)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/AsayuGit/YetAnotherSlotProject.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitName
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_gitName
+ make
+}
+
+package() {
+ cd $_gitName
+ make DESTDIR="$pkgdir/" install
+}