summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--boringssl-gcc-14.patch22
-rw-r--r--cmake.patch29
4 files changed, 8 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c6dd8e06a4f..0ddaa16397f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yass-proxy
pkgdesc = lightweight http/socks proxy
- pkgver = 1.9.5
- pkgrel = 3
+ pkgver = 1.10.0
+ pkgrel = 1
url = https://github.com/Chilledheart/yass
arch = x86_64
license = GPL-2.0-only
@@ -27,13 +27,9 @@ pkgbase = yass-proxy
optdepends = gtk-update-icon-cache
provides = yass-proxy
conflicts = yass-proxy-git
- source = https://github.com/Chilledheart/yass/releases/download/1.9.5/yass-1.9.5.tar.bz2
- source = boringssl-gcc-14.patch
+ source = https://github.com/Chilledheart/yass/releases/download/1.10.0/yass-1.10.0.tar.bz2
source = libcxx-gcc-14.patch
- source = cmake.patch
- sha256sums = 26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635
- sha256sums = 6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662
+ sha256sums = 3140611a5f70148664fd54cb2db8aa6b178395eeec56ffdc6b5dd22b011e0a6f
sha256sums = 72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4
- sha256sums = 24cef2470a32381e771ce110e5bae4f1f96e589e9d59a3aa6c294ba5cf6a8d71
pkgname = yass-proxy
diff --git a/PKGBUILD b/PKGBUILD
index c64ae9da754c..b162f85f57d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Chilledheart <hukeyue@hotmail.com>
pkgname=yass-proxy
-pkgver=1.9.5
-pkgrel=3
-_pkgver=1.9.5
+pkgver=1.10.0
+pkgrel=1
+_pkgver=1.10.0
_pkgrel=1
pkgdesc="lightweight http/socks proxy"
arch=(x86_64)
@@ -17,22 +17,16 @@ checkdepends=(curl)
provides=(yass-proxy)
conflicts=(yass-proxy-git)
source=("https://github.com/Chilledheart/yass/releases/download/${_pkgver}/yass-${_pkgver}.tar.bz2"
- "boringssl-gcc-14.patch"
"libcxx-gcc-14.patch"
- "cmake.patch"
)
-sha256sums=('26e013c811f0b4cb194bfd4587fa6e644b5f155593df0c6a15c026120084a635'
- '6201584f8c5c983405e07f99a83e33a28e1aa907a752bc07bc641d0cf1087662'
+sha256sums=('3140611a5f70148664fd54cb2db8aa6b178395eeec56ffdc6b5dd22b011e0a6f'
'72f55c55adb141d31dd9cd892cd04a08df2d95a1d94ad3a4b421a312075782e4'
- '24cef2470a32381e771ce110e5bae4f1f96e589e9d59a3aa6c294ba5cf6a8d71'
)
prepare() {
SRC_DIR="${srcdir}/yass-${_pkgver}"
pushd $SRC_DIR
- patch --forward --strip=1 --input=../boringssl-gcc-14.patch
patch --forward --strip=1 --input=../libcxx-gcc-14.patch
- patch --forward --strip=1 --input=../cmake.patch
cd tools
go build
cd ..
diff --git a/boringssl-gcc-14.patch b/boringssl-gcc-14.patch
deleted file mode 100644
index 366e21f458d1..000000000000
--- a/boringssl-gcc-14.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/third_party/boringssl/src/crypto/internal.h b/third_party/boringssl/src/crypto/internal.h
-index 762eaae8c..27652fbe9 100644
---- a/third_party/boringssl/src/crypto/internal.h
-+++ b/third_party/boringssl/src/crypto/internal.h
-@@ -1201,7 +1201,7 @@ static inline uint64_t CRYPTO_rotr_u64(uint64_t value, int shift) {
-
- // CRYPTO_addc_* returns |x + y + carry|, and sets |*out_carry| to the carry
- // bit. |carry| must be zero or one.
--#if OPENSSL_HAS_BUILTIN(__builtin_addc)
-+#if OPENSSL_HAS_BUILTIN(__builtin_addc) && !defined(__cplusplus)
-
- #define CRYPTO_GENERIC_ADDC(x, y, carry, out_carry) \
- (_Generic((x), \
-@@ -1253,7 +1253,7 @@ static inline uint64_t CRYPTO_addc_u64(uint64_t x, uint64_t y, uint64_t carry,
-
- // CRYPTO_subc_* returns |x - y - borrow|, and sets |*out_borrow| to the borrow
- // bit. |borrow| must be zero or one.
--#if OPENSSL_HAS_BUILTIN(__builtin_subc)
-+#if OPENSSL_HAS_BUILTIN(__builtin_subc) && !defined(__cplusplus)
-
- #define CRYPTO_GENERIC_SUBC(x, y, borrow, out_borrow) \
- (_Generic((x), \
diff --git a/cmake.patch b/cmake.patch
deleted file mode 100644
index 9afd461a6cac..000000000000
--- a/cmake.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-commit dabb3237db4112abde0020cbb0b6a80f477e6aee
-Author: Keeyou <keeyou-cn@outlook.com>
-Date: Sat May 11 10:55:46 2024 +0800
-
- gperftools: set benchmark to off (trivial)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a36248d9..98942410 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2411,12 +2411,12 @@ if (USE_SYSTEM_TCMALLOC AND USE_TCMALLOC)
- elseif (USE_TCMALLOC)
- message(STATUS "Compiling with bundled tcmalloc support")
-
-- set(GPERFTOOLS_BUILD_DEBUGALLOC OFF)
-- set(gperftools_build_minimal ON)
-- set(gperftools_build_benchmark OFF)
-- set(GPERFTOOLS_BUILD_STATIC ON)
-- set(GPERFTOOLS_ENABLE_INSTALL OFF)
-- set(GPERFTOOLS_BUILD_TESTING OFF)
-+ set(GPERFTOOLS_BUILD_DEBUGALLOC OFF CACHE BOOL "")
-+ set(gperftools_build_minimal ON CACHE BOOL "")
-+ set(gperftools_build_benchmark OFF CACHE BOOL "")
-+ set(GPERFTOOLS_BUILD_STATIC ON CACHE BOOL "")
-+ set(GPERFTOOLS_ENABLE_INSTALL OFF CACHE BOOL "")
-+ set(GPERFTOOLS_BUILD_TESTING OFF CACHE BOOL "")
- add_subdirectory(third_party/gperftools)
-
- set_target_properties(tcmalloc_minimal PROPERTIES EXCLUDE_FROM_ALL TRUE)