summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--LICENSE14
-rw-r--r--PKGBUILD46
-rw-r--r--yatqa12
-rw-r--r--yatqa.desktop8
-rw-r--r--yatqa.install3
6 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cac6658258cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = yatqa
+ pkgdesc = Tool for managing TeamSpeak 3 servers and instances
+ pkgver = 3.9rc1
+ pkgrel = 1
+ url = http://yat.qa/
+ install = yatqa.install
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = p7zip
+ makedepends = icoutils
+ depends = wine
+ source = http://yat.qa/YaTQA-Setup_3.9-rc1.exe
+ source = yatqa
+ source = yatqa.desktop
+ source = yatqa.install
+ source = LICENSE
+ sha256sums = 2e39ae48c80fbe3221e60de20a1d7920e24f93f5367851593650b7268163cb50
+ sha256sums = 57fcd761e93b6f5d8bd6f4e354aafc9174ecdeea0fe39ea89dc68245b3c9ce02
+ sha256sums = 98c8f8313858f9fd7a00f75001effcf298b8b1bc43e142ac3e361016f5be9c6f
+ sha256sums = 45fe54d9f4655abb6774a01c961ee547507a92c2499645164f14ea5b1dc1a55a
+ sha256sums = f2e3a5f026505316e61905695317531717e213b2d497132a351748efc861ce5f
+
+pkgname = yatqa
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..79643a6ab1bc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,14 @@
+Yet another TeamSpeak³ Query App, http://yat.qa/ (the Software)
+Copyright © 2011-2017 JN-GAMES Software, http://jn-games.de/ (the Author)
+
+The Software is donationware for personal use. You may copy it to your friends free of charge, but I'd be happy if you consider making a donation.
+For commercial use, the Software is licensed under a pay-what-you-want model. More info can be found in the Software.
+If you decide to register, you may not share your registration key with anyone.
+
+You may not redistribute this installer file or any file of the Software itself publicly via the internet. Please link to http://yat.qa/ instead.
+
+
+Source code is available on request by people who think about improving the tool.
+
+The Software is distributed "as is", without warranty of any kind, expressed or implied, including, but not limited to warranty of fitness for any particular purpose. In no event will the Author be liable to you for any special, incidental, indirect, consequential or any other damages caused by the use, misuse, or the inability to use of the Software, including any lost profits or lost savings, even if the Author has been advised of the possibility of such damages.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f79b112eccad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Caesim404 <caesim404 at gmail dot com>
+
+pkgname="yatqa"
+_pkgver="3.9-rc1"
+pkgver="${_pkgver/-/}"
+pkgrel="1"
+pkgdesc="Tool for managing TeamSpeak 3 servers and instances"
+arch=("x86_64" "i686")
+url="http://yat.qa/"
+license=("custom")
+depends=("wine")
+makedepends=("p7zip" "icoutils")
+install="yatqa.install"
+source=("http://yat.qa/YaTQA-Setup_${_pkgver}.exe"
+ "yatqa"
+ "yatqa.desktop"
+ "yatqa.install"
+ "LICENSE")
+sha256sums=('2e39ae48c80fbe3221e60de20a1d7920e24f93f5367851593650b7268163cb50'
+ '57fcd761e93b6f5d8bd6f4e354aafc9174ecdeea0fe39ea89dc68245b3c9ce02'
+ '98c8f8313858f9fd7a00f75001effcf298b8b1bc43e142ac3e361016f5be9c6f'
+ '45fe54d9f4655abb6774a01c961ee547507a92c2499645164f14ea5b1dc1a55a'
+ 'f2e3a5f026505316e61905695317531717e213b2d497132a351748efc861ce5f')
+
+build() {
+ cd "${srcdir}"
+
+ 7z x -aos "YaTQA-Setup_${_pkgver}.exe" yatqa.exe yatqa.ini
+
+ wrestool -x -t 14 -o yatqa.ico yatqa.exe
+ icotool -x -w 144 -o yatqa.png yatqa.ico
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm644 yatqa.exe "${pkgdir}/usr/share/yatqa/yatqa.exe"
+ install -Dm644 yatqa.ini "${pkgdir}/usr/share/yatqa/yatqa.ini"
+
+ install -Dm755 yatqa "${pkgdir}/usr/bin/yatqa"
+
+ install -Dm644 yatqa.desktop "${pkgdir}/usr/share/applications/yatqa.desktop"
+ install -Dm644 yatqa.png "${pkgdir}/usr/share/pixmaps/yatqa.png"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/yatqa/LICENSE"
+}
diff --git a/yatqa b/yatqa
new file mode 100644
index 000000000000..bc18a55f4d68
--- /dev/null
+++ b/yatqa
@@ -0,0 +1,12 @@
+#!/usr/bin/bash
+
+export WINEARCH=win32 WINEPREFIX="$HOME/.yatqa/wine" WINEDLLOVERRIDES="mscoree,mshtml="
+
+if [ ! -d "$HOME/.yatqa" ] ; then
+ mkdir -p "$HOME/.yatqa/wine"
+
+ ln -s /usr/share/yatqa/yatqa.exe "$HOME/.yatqa"
+ cp /usr/share/yatqa/yatqa.ini "$HOME/.yatqa"
+fi
+
+wine "$HOME/.yatqa/yatqa.exe"
diff --git a/yatqa.desktop b/yatqa.desktop
new file mode 100644
index 000000000000..d8b9e14614ba
--- /dev/null
+++ b/yatqa.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=YaTQA
+Comment=Tool for managing TeamSpeak 3 servers and instances
+Exec=yatqa
+Icon=yatqa
+Terminal=false
+Type=Application
+Categories=Utility;
diff --git a/yatqa.install b/yatqa.install
new file mode 100644
index 000000000000..019d61c6c3a6
--- /dev/null
+++ b/yatqa.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'The config is located at ~/.yatqa/yatqa.ini'
+}