summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
2 files changed, 8 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 179e8a390679..4edb05364a0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yay
pkgdesc = Yet another yogurt. Pacman wrapper and AUR helper written in go.
- pkgver = 4.505
+ pkgver = 5.608
pkgrel = 1
url = https://github.com/Jguer/yay
arch = i686
@@ -16,8 +16,8 @@ pkgbase = yay
conflicts = yay-git
options = !strip
options = !emptydirs
- source = https://github.com/Jguer/yay/archive/v4.505.tar.gz
- sha1sums = 9918ce6ccb09a988b80eb38156f141f78a84add5
+ source = https://github.com/Jguer/yay/archive/v5.608.tar.gz
+ sha1sums = bc8bc58a9e48befe6ae9def129a021a49cc9c1a0
pkgname = yay
diff --git a/PKGBUILD b/PKGBUILD
index 76bf75b7fd76..decbb554eeb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jguer <joaogg3@gmail.com>
pkgname=yay
-pkgver=4.505
+pkgver=5.608
pkgrel=1
pkgdesc="Yet another yogurt. Pacman wrapper and AUR helper written in go."
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
@@ -16,36 +16,14 @@ makedepends=(
)
conflicts=('yay-bin' 'yay-git')
source=("https://github.com/Jguer/yay/archive/v${pkgver}.tar.gz")
-sha1sums=('9918ce6ccb09a988b80eb38156f141f78a84add5')
-
-prepare() {
- export GOPATH="${srcdir}/.go"
- export GOBIN="$GOPATH/bin"
- mkdir -p "$GOPATH"
- rm -rf "$GOPATH/src"
- ln -sf "$srcdir/$pkgname-$pkgver/vendor" "$GOPATH/src"
-}
+sha1sums=('bc8bc58a9e48befe6ae9def129a021a49cc9c1a0')
build() {
- export GOPATH="${srcdir}/.go"
- export GOBIN="$GOPATH/bin"
cd "$srcdir/$pkgname-$pkgver"
- go build -v -o ${pkgname} -ldflags "-s -w -X main.version=${pkgver}"
+ make VERSION=$pkgver
}
package() {
- _output="${srcdir}/$pkgname-$pkgver"
- install -Dm755 "${_output}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
-
- # Install manpage
- install -Dm644 "${_output}/yay.8" "${pkgdir}/usr/share/man/man8/yay.8"
-
- # Install bash completion
- install -Dm644 "${_output}/bash-completion" "${pkgdir}/usr/share/bash-completion/completions/yay"
-
- # Install zsh completion
- install -Dm644 "${_output}/zsh-completion" "${pkgdir}/usr/share/zsh/site-functions/_yay"
-
- # Install fish completion
- install -Dm644 "${_output}/yay.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/yay.fish"
+ cd "$srcdir/$pkgname-$pkgver"
+ make VERSION=$pkgver DESTDIR="$pkgdir" install
}