summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d25d3998619c..8392ccf8e402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ycmd-git
pkgdesc = A code-completion & code-comprehension server
- pkgver = r1969.1c190032
+ pkgver = r2028.702222bb
pkgrel = 1
url = https://github.com/Valloric/ycmd
arch = i686
@@ -15,7 +15,8 @@ pkgbase = ycmd-git
source = git+https://github.com/Valloric/ycmd.git
source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/slezica/python-frozendict.git
- source = git+https://github.com/vheon/JediHTTP.git
+ source = git+https://github.com/davidhalter/jedi.git
+ source = git+https://github.com/davidhalter/parso.git
source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/requests/requests.git
source = git+https://github.com/Pylons/waitress.git
@@ -26,6 +27,7 @@ pkgbase = ycmd-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = ycmd-git
diff --git a/PKGBUILD b/PKGBUILD
index 8e7df3e1edc3..afd825ccf1e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ycmd-git
_gitname=ycmd
-pkgver=r1969.1c190032
+pkgver=r2028.702222bb
pkgrel=1
pkgdesc="A code-completion & code-comprehension server"
arch=('i686' 'x86_64')
@@ -15,11 +15,12 @@ conflicts=('ycmd')
source=("git+https://github.com/Valloric/ycmd.git"
"git+https://github.com/bottlepy/bottle.git"
"git+https://github.com/slezica/python-frozendict.git"
- "git+https://github.com/vheon/JediHTTP.git"
+ "git+https://github.com/davidhalter/jedi.git"
+ "git+https://github.com/davidhalter/parso.git"
"git+https://github.com/PythonCharmers/python-future.git"
"git+https://github.com/requests/requests.git"
"git+https://github.com/Pylons/waitress.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -30,13 +31,15 @@ prepare() {
cd "$srcdir/$_gitname"
git submodule init third_party/bottle \
third_party/frozendict \
- third_party/JediHTTP \
+ third_party/jedi \
+ third_party/parso \
third_party/python-future \
third_party/requests \
third_party/waitress
git config submodule.third_party/bottle.url $srcdir/bottle
git config submodule.third_party/frozendict.url $srcdir/python-frozendict
- git config submodule.third_party/JediHTTP.url $srcdir/JediHTTP
+ git config submodule.third_party/jedi.url $srcdir/jedi
+ git config submodule.third_party/parso.url $srcdir/parso
git config submodule.third_party/python-future.url $srcdir/python-future
git config submodule.third_party/requests.url $srcdir/requests
git config submodule.third_party/waitress.url $srcdir/waitress
@@ -56,7 +59,7 @@ package() {
mkdir -p "$pkgdir/$trgtdir/third_party"
cp -r "$srcdir/$_gitname/"{ycmd,ycm_core.so,CORE_VERSION,cpp,clang_includes} \
"$pkgdir/$trgtdir"
- cp -r "$srcdir/$_gitname/third_party/"{bottle,frozendict,JediHTTP,python-future,requests,waitress} \
+ cp -r "$srcdir/$_gitname/third_party/"{bottle,frozendict,jedi,parso,python-future,requests,waitress} \
"$pkgdir/$trgtdir/third_party"
find "$pkgdir" -name .git -exec rm -fr {} +
rm -rf "$pkgdir/$trgtdir/ycmd/tests"