summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3570918afd1..1d87827c3c96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ycmd-git
pkgdesc = A code-completion & code-comprehension server
- pkgver = r2474.6f3e2ac5
+ pkgver = r2493.f8f50d4e
pkgrel = 1
url = https://github.com/Valloric/ycmd
arch = i686
@@ -23,6 +23,8 @@ pkgbase = ycmd-git
source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/requests/requests.git
source = git+https://github.com/Pylons/waitress.git
+ source = git+https://github.com/davidhalter/typeshed.git
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bf9dcd7da23b..bb6c9be2de2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ycmd-git
_gitname=ycmd
-pkgver=r2474.6f3e2ac5
+pkgver=r2493.f8f50d4e
pkgrel=1
pkgdesc="A code-completion & code-comprehension server"
arch=('i686' 'x86_64')
@@ -19,8 +19,9 @@ source=("git+https://github.com/Valloric/ycmd.git"
"git+https://github.com/davidhalter/parso.git"
"git+https://github.com/PythonCharmers/python-future.git"
"git+https://github.com/requests/requests.git"
- "git+https://github.com/Pylons/waitress.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ "git+https://github.com/Pylons/waitress.git"
+ "git+https://github.com/davidhalter/typeshed.git")
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -44,6 +45,9 @@ prepare() {
git config submodule.third_party/requests_deps/requests.url $srcdir/requests_deps/requests
git config submodule.third_party/waitress.url $srcdir/waitress
git submodule update
+ cd "third_party/jedi_deps/jedi"
+ git config submodule.jedi/third_party/typeshed.url "$srcdir"/typeshed
+ git submodule update
}
build() {