summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 509942b69bb9..949cb1dbebed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ycmd-git
pkgdesc = A code-completion & code-comprehension server
- pkgver = r2509.d02aec3d
+ pkgver = r2548.d3378ca3
pkgrel = 1
url = https://github.com/Valloric/ycmd
arch = i686
@@ -19,7 +19,6 @@ pkgbase = ycmd-git
source = git+https://github.com/bottlepy/bottle.git
source = git+https://github.com/davidhalter/jedi.git
source = git+https://github.com/davidhalter/parso.git
- source = git+https://github.com/PythonCharmers/python-future.git
source = git+https://github.com/requests/requests.git
source = git+https://github.com/Pylons/waitress.git
source = git+https://github.com/davidhalter/typeshed.git
@@ -30,7 +29,6 @@ pkgbase = ycmd-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = ycmd-git
diff --git a/PKGBUILD b/PKGBUILD
index 0157a16032be..13c7e200e3fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ycmd-git
_gitname=ycmd
-pkgver=r2509.d02aec3d
+pkgver=r2548.d3378ca3
pkgrel=1
pkgdesc="A code-completion & code-comprehension server"
arch=('i686' 'x86_64')
@@ -16,11 +16,10 @@ source=("git+https://github.com/Valloric/ycmd.git"
"git+https://github.com/bottlepy/bottle.git"
"git+https://github.com/davidhalter/jedi.git"
"git+https://github.com/davidhalter/parso.git"
- "git+https://github.com/PythonCharmers/python-future.git"
"git+https://github.com/requests/requests.git"
"git+https://github.com/Pylons/waitress.git"
"git+https://github.com/davidhalter/typeshed.git")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -32,13 +31,11 @@ prepare() {
git submodule init third_party/bottle \
third_party/jedi_deps/jedi \
third_party/jedi_deps/parso \
- third_party/python-future \
third_party/requests_deps/requests \
third_party/waitress
git config submodule.third_party/bottle.url $srcdir/bottle
git config submodule.third_party/jedi_deps/jedi.url $srcdir/jedi_deps/jedi
git config submodule.third_party/jedi_deps/parso.url $srcdir/jedi_deps/parso
- git config submodule.third_party/python-future.url $srcdir/python-future
git config submodule.third_party/requests_deps/requests.url $srcdir/requests_deps/requests
git config submodule.third_party/waitress.url $srcdir/waitress
git submodule update
@@ -60,7 +57,7 @@ package() {
mkdir -p "$pkgdir/$trgtdir/third_party"
cp -r "$srcdir/$_gitname/"{ycmd,ycm_core.so,CORE_VERSION,cpp} \
"$pkgdir/$trgtdir"
- cp -r "$srcdir/$_gitname/third_party/"{bottle,clang,jedi_deps,python-future,requests_deps,waitress} \
+ cp -r "$srcdir/$_gitname/third_party/"{bottle,clang,jedi_deps,requests_deps,waitress} \
"$pkgdir/$trgtdir/third_party"
find "$pkgdir" -name .git -exec rm -fr {} +
rm -rf "$pkgdir/$trgtdir/ycmd/tests"