summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--make_it_build.patch12
3 files changed, 8 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3ee831b666..efcfc8533016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = yefm
pkgdesc = Simple 2 panes file manager
pkgver = 0.2
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/yede/yefm.git
arch = i686
arch = x86_64
license = GPL
depends = qt5-base
- source = yefm-0.2.zip::https://github.com/yede/yefm/archive/master.zip
- source = make_it_build.patch
- sha256sums = 2b83475c82932c94de2c6d47f111cd0642564d1f5e3a7d316ff96560329873ad
- sha256sums = f6e71d701bb7732c2460a0c2db0e1afb54704fae3a8fdb3d9556e4f674513653
+ source = https://gitlab.com/stefanhusmann/yefm/-/archive/0.2/yefm-0.2.tar.bz2
+ sha256sums = 4b9313da92f009a70ffa2b05db578519f1066e13eb651bc33c92f7b62bf07835
pkgname = yefm
diff --git a/PKGBUILD b/PKGBUILD
index c02160091e70..027bf3751a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,22 @@
pkgname=yefm
pkgver=0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Simple 2 panes file manager"
url="https://github.com/yede/yefm.git"
arch=('i686' 'x86_64')
license=('GPL')
depends=('qt5-base')
-source=("$pkgname-$pkgver.zip::https://github.com/yede/$pkgname/archive/master.zip" make_it_build.patch)
-sha256sums=('2b83475c82932c94de2c6d47f111cd0642564d1f5e3a7d316ff96560329873ad'
- 'f6e71d701bb7732c2460a0c2db0e1afb54704fae3a8fdb3d9556e4f674513653')
-
-prepare() {
- cd $pkgname-master
- patch -Np1 < "$srcdir"/make_it_build.patch
-}
+source=("https://gitlab.com/stefanhusmann/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2")
+sha256sums=('4b9313da92f009a70ffa2b05db578519f1066e13eb651bc33c92f7b62bf07835')
build() {
- cd $pkgname-master
+ cd $pkgname-$pkgver
qmake-qt5 $pkgname.pro
make
}
package() {
- cd $pkgname-master
+ cd $pkgname-$pkgver
make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/make_it_build.patch b/make_it_build.patch
deleted file mode 100644
index 2cab6065b242..000000000000
--- a/make_it_build.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur yefm-orig/appui/yefilepane.h yefm-new/appui/yefilepane.h
---- yefm-orig/appui/yefilepane.h 2017-10-29 19:29:05.342478202 +0100
-+++ yefm-new/appui/yefilepane.h 2017-10-29 19:29:21.195717301 +0100
-@@ -1,7 +1,7 @@
- #ifndef YEFILEPANE_H
- #define YEFILEPANE_H
-
--#include <QWidget>
-+#include <QtWidgets/QWidget>
- //==============================================================================================================================
-
- class QMenu;