summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--make_it_build.patch12
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..239fea1ebd66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Oct 29 18:31:59 UTC 2017
+pkgbase = yefm
+ pkgdesc = Simple 2 panes file manager
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/yede/yefm.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ source = yefm-0.2.zip::https://github.com/yede/yefm/archive/master.zip
+ source = make_it_build.patch
+ md5sums = 9321399a80c9fb19a984e4781c3ec630
+ md5sums = 07aa7faaa650ac6500d37fadc079d23b
+
+pkgname = yefm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66c376e2785f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=yefm
+pkgver=0.2
+pkgrel=1
+pkgdesc="Simple 2 panes file manager"
+url="https://github.com/yede/yefm.git"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('qt5-base')
+source=("$pkgname-$pkgver.zip::https://github.com/yede/$pkgname/archive/master.zip" make_it_build.patch)
+md5sums=('9321399a80c9fb19a984e4781c3ec630'
+ '07aa7faaa650ac6500d37fadc079d23b')
+
+prepare() {
+ cd $srcdir/$pkgname-master
+ patch -Np1 < "$srcdir"/make_it_build.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-master
+ qmake-qt5 $pkgname.pro
+ make
+}
+package() {
+ cd $srcdir/$pkgname-master
+ make INSTALL_ROOT="${pkgdir}" install
+}
+
diff --git a/make_it_build.patch b/make_it_build.patch
new file mode 100644
index 000000000000..2cab6065b242
--- /dev/null
+++ b/make_it_build.patch
@@ -0,0 +1,12 @@
+diff -Naur yefm-orig/appui/yefilepane.h yefm-new/appui/yefilepane.h
+--- yefm-orig/appui/yefilepane.h 2017-10-29 19:29:05.342478202 +0100
++++ yefm-new/appui/yefilepane.h 2017-10-29 19:29:21.195717301 +0100
+@@ -1,7 +1,7 @@
+ #ifndef YEFILEPANE_H
+ #define YEFILEPANE_H
+
+-#include <QWidget>
++#include <QtWidgets/QWidget>
+ //==============================================================================================================================
+
+ class QMenu;