summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e2e9676e7ee..9061d561b668 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Sun Feb 3 09:59:46 UTC 2019
+# Sun Feb 3 10:10:46 UTC 2019
pkgbase = yetris-git
- pkgdesc = Customizable Tetris(tm) for the terminal - unstable development version
+ pkgdesc = Customizable Tetris(tm) for the terminal.
pkgver = 20150103
pkgrel = 1
url = http://www.github.com/alexdantas/yetris/
@@ -11,8 +11,8 @@ pkgbase = yetris-git
makedepends = git
depends = ncurses
conflicts = yetris
- source = yetris-git::git+https://github.com/alexdantas/yetris.git
- sha256sums = SKIP
+ source = yetris-git::git+https://github.com/alexdantas/yetris
+ md5sums = SKIP
pkgname = yetris-git
diff --git a/PKGBUILD b/PKGBUILD
index 93c8a88a42f7..8551ef3c37f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,32 @@
# Contributor: Lucas de Sena <lucas DOT ta23 @ gmail DOT com>
-# Maintainer: Alexandre Dantas <eu @ alexdantas DOT net>
# Contributor: Shizeeg Unadequatov <shizeeque @ gmail DOT com>
-
+# Contributor: Alexandre Dantas <eu @ alexdantas DOT net>
+# Maintainer: aksr <aksr at t-com dot me>
pkgname=yetris-git
pkgver=20150103
pkgrel=1
-pkgdesc="Customizable Tetris(tm) for the terminal - unstable development version"
+pkgdesc='Customizable Tetris(tm) for the terminal.'
arch=('x86_64' 'i686')
url="http://www.github.com/alexdantas/yetris/"
license=('GPL3')
depends=('ncurses')
makedepends=('git')
-conflicts=('yetris')
-
-source=("$pkgname::git+https://github.com/alexdantas/yetris.git")
-sha256sums=('SKIP')
+conflicts=("${pkgname%-*}")
+source=("$pkgname::git+https://github.com/alexdantas/yetris")
+md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
-# git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd "$srcdir/$pkgname"
git log -1 --date=short | grep 'Date:' | sed 's|[^0-9]||g'
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "$srcdir/$pkgname"
make
}
package() {
- cd "${srcdir}/${pkgname}"
-
- make DESTDIR="$pkgdir" PREFIX="/usr/local" install
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
}
+