summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31d20e7c68f1..0f382ef27eb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = yip-git
- pkgdesc = Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (Development version)
- pkgver = 0.1.2.r0.gdbcdd0d
+ pkgdesc = Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (development version)
+ pkgver = 0.1.3.r4.g164de8a
pkgrel = 1
url = https://github.com/jenspots/yip
arch = x86_64
license = AGPL-3.0
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ provides = yip
+ conflicts = yip
source = yip-git::git+https://github.com/jenspots/yip#branch=main
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 19a68f581cc7..6287df913283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,20 @@
# Maintainer: Jef Roosens
-pkgbase=yip-git
pkgname=yip-git
-pkgver=0.1.2.r0.gdbcdd0d
+pkgver=0.1.3.r4.g164de8a
pkgrel=1
-pkgdesc="Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (Development version)"
+pkgdesc="Performant, lightweight HTTP server that echoes the client's IP address, written in plain C. (development version)"
arch=('x86_64')
url='https://github.com/jenspots/yip'
license=('AGPL-3.0')
+depends=('glibc')
+makedepends=('git' 'cmake')
+
+provides=('yip')
+conflicts=('yip')
+
source=("${pkgname}::git+https://github.com/jenspots/yip#branch=main")
md5sums=('SKIP')
@@ -18,12 +23,13 @@ pkgver() {
}
build() {
- cd "${pkgname}"
-
- gcc -o yip -O3 -lpthread yip.c
+ cmake -B build -S "${pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
}
package() {
- install -Dm755 "${pkgname}/yip" "${pkgdir}/usr/bin/yip"
- install -Dm644 "${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/LICENSE"
+ DESTDIR="${pkgdir}" cmake --install build
}