summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
-rw-r--r--configargparse.patch12
3 files changed, 13 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40aa8fd61a95..29727663b2ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yle-dl
pkgdesc = Download video and audio from YLE Areena.
- pkgver = 20181221
- pkgrel = 3
+ pkgver = 20190203
+ pkgrel = 1
url = http://aajanki.github.io/yle-dl/
arch = any
license = GPL3
@@ -15,14 +15,12 @@ pkgbase = yle-dl
depends = python-mini-amf
depends = python-pycryptodomex
depends = python-requests
- depends = wget
optdepends = php: for downloading live TV and certain news broadcasts
- optdepends = rtmpdump: for downloading Areena audio streams
+ optdepends = rtmpdump: for downloading some Elävä Arkisto streams
optdepends = youtube-dl: an alternative downloader backend to AdobeHDS.php
- source = yle-dl-20181221.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20181221.tar.gz
- source = configargparse.patch
- sha256sums = 8970960816151d0e296c0ab15b9371c0feea444567c59a7b2917bdf5f0de06fd
- sha256sums = cfdf7268d945e1f03d5911acdf54900672083f08574cc1e887e134ae097e45d8
+ optdepends = wget: for some rare streams
+ source = yle-dl-20190203.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-20190203.tar.gz
+ sha256sums = 81c3096162657d3d8e9e9a2b4d277261b8be4c8696a31505b1f9b6352cf9996f
pkgname = yle-dl
diff --git a/PKGBUILD b/PKGBUILD
index 5e6ed3b0c7fa..1850a8c1d4e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: ZaZam <zazaamm ät gmail dt com>
pkgname=yle-dl
-pkgver=20181221
-pkgrel=3
+pkgver=20190203
+pkgrel=1
pkgdesc="Download video and audio from YLE Areena."
arch=('any')
url="http://aajanki.github.io/yle-dl/"
@@ -18,17 +18,14 @@ depends=('ffmpeg'
'python-mini-amf'
'python-pycryptodomex'
'python-requests'
- 'wget'
)
optdepends=('php: for downloading live TV and certain news broadcasts'
- 'rtmpdump: for downloading Areena audio streams'
- 'youtube-dl: an alternative downloader backend to AdobeHDS.php')
+ 'rtmpdump: for downloading some Elävä Arkisto streams'
+ 'youtube-dl: an alternative downloader backend to AdobeHDS.php'
+ 'wget: for some rare streams')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-${pkgver}.tar.gz"
- 'configargparse.patch'
-)
-sha256sums=('8970960816151d0e296c0ab15b9371c0feea444567c59a7b2917bdf5f0de06fd'
- 'cfdf7268d945e1f03d5911acdf54900672083f08574cc1e887e134ae097e45d8')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/y/yle-dl/yle-dl-${pkgver}.tar.gz")
+sha256sums=('81c3096162657d3d8e9e9a2b4d277261b8be4c8696a31505b1f9b6352cf9996f')
prepare() {
cd $pkgname-$pkgver
diff --git a/configargparse.patch b/configargparse.patch
deleted file mode 100644
index 0317d7e0eeb4..000000000000
--- a/configargparse.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ura package.orig/yle-dl-20181221/setup.py package.new/yle-dl-20181221/setup.py
---- yle-dl-20181221/setup.py 2018-11-03 11:51:18.000000000 +0200
-+++ yle-dl-20181221/setup.py 2019-01-29 14:37:48.871293859 +0200
-@@ -39,7 +39,7 @@
- include_package_data=True,
- install_requires=[
- 'pycryptodomex', 'requests', 'lxml', 'future', 'mini-amf',
-- 'attrs >= 18.1.0, < 18.3.0', 'ConfigArgParse == 0.13.0'
-+ 'attrs >= 18.1.0, < 18.3.0', 'ConfigArgParse >= 0.13.0'
- ] + ssl_sni_requires,
- extras_require = {
- 'youtubedl-backend': ['youtube_dl']