summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..177abe9bf70f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = yofi
+ pkgdesc = Minimalistic menu for Wayland-based compositors.
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/l4l/yofi
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = fontconfig
+ depends = expat
+ depends = graphite
+ depends = pcre
+ depends = wayland-protocols
+ depends = libxkbcommon
+ source = https://github.com/l4l/yofi/archive/0.1.3.tar.gz
+ sha256sums = 9b1a61450a9abc4c2b7604a45bf1637efe33acb0f339b9858736b5b92738e61f
+
+pkgname = yofi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eafafddca3e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Kitsu mail@kitsu.me
+
+pkgname=yofi
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Minimalistic menu for Wayland-based compositors."
+arch=('x86_64')
+url="https://github.com/l4l/yofi"
+license=('MIT')
+depends=('fontconfig' 'expat' 'graphite' 'pcre' 'wayland-protocols' 'libxkbcommon')
+makedepends=('cargo')
+source=("https://github.com/l4l/yofi/archive/0.1.3.tar.gz")
+sha256sums=('9b1a61450a9abc4c2b7604a45bf1637efe33acb0f339b9858736b5b92738e61f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ install -Dm755 "target/release/yofi" "$pkgdir/usr/bin/yofi"
+}
+