summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
-rw-r--r--UNLICENSE24
-rwxr-xr-xyoutube-dl-gui5
-rw-r--r--youtube-dl-gui.desktop8
5 files changed, 10 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51de845464f7..fc55cb7fae79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = youtube-dl-gui-git
pkgdesc = Cross platform front-end GUI of the popular youtube-dl written in wxPython
- pkgver = 1.7.0.r12.g8dbf054
+ pkgver = 1.8.4.r22.g23ccbc4
pkgrel = 1
url = https://github.com/oleksis/youtube-dl-gui
arch = any
@@ -16,8 +16,6 @@ pkgbase = youtube-dl-gui-git
provides = youtube-dl-gui
conflicts = youtube-dl-gui
source = youtube-dl-gui-git::git+https://github.com/oleksis/youtube-dl-gui.git
- source = youtube-dl-gui.desktop
sha256sums = SKIP
- sha256sums = 0c98a9550084bf7b9fd1ac9c394c6499a129b9d439bab6a256b3a1f4695ce358
pkgname = youtube-dl-gui-git
diff --git a/PKGBUILD b/PKGBUILD
index a5a52041de34..37e991724d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: B4SH-B00STER
pkgname=youtube-dl-gui-git
-pkgver=1.7.0.r12.g8dbf054
+pkgver=1.8.4.r22.g23ccbc4
pkgrel=1
pkgdesc="Cross platform front-end GUI of the popular youtube-dl written in wxPython"
arch=('any')
@@ -15,10 +15,8 @@ optdepends=('ffmpeg: convert video files to audio-only files'
makedepends=('git' 'python-polib' 'python-setuptools')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
-source=($pkgname::git+$url.git
- youtube-dl-gui.desktop)
-sha256sums=('SKIP'
- '0c98a9550084bf7b9fd1ac9c394c6499a129b9d439bab6a256b3a1f4695ce358')
+source=($pkgname::git+$url.git)
+sha256sums=('SKIP')
pkgver() {
git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -30,17 +28,16 @@ pkgver() {
#}
package() {
- install -Dm644 youtube-dl-gui.desktop -t "$pkgdir/usr/share/applications"
- install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
-
cd $pkgname
python setup.py build_trans install --root="$pkgdir" --optimize=1 # --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -Dm644 yt-dlg.desktop -t "$pkgdir/usr/share/applications"
}
# # Following the upstream build instructions
-# # Change the Exec= line in youtube-dl-gui.desktop to Exec=youtube-dl-gui
#
# pkgname=youtube-dl-gui-git
# pkgver=0
@@ -57,12 +54,8 @@ package() {
# makedepends=('git')
# provides=(${pkgname%-git})
# conflicts=(${pkgname%-git})
-# source=($pkgname::git+$url.git
-# youtube-dl-gui.desktop
-# youtube-dl-gui)
-# sha256sums=('SKIP'
-# '0'
-# '0')
+# source=($pkgname::git+$url.git youtube-dl-gui)
+# sha256sums=('SKIP' '0')
#
# pkgver() {
# git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -77,8 +70,7 @@ package() {
#
# package() {
# install -Dm755 youtube-dl-gui -t "$pkgdir/usr/bin"
-# install -Dm644 youtube-dl-gui.desktop -t "$pkgdir/usr/share/applications"
-# install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+# install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
#
# cd $pkgname
#
diff --git a/UNLICENSE b/UNLICENSE
deleted file mode 100644
index 68a49daad8ff..000000000000
--- a/UNLICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <http://unlicense.org/>
diff --git a/youtube-dl-gui b/youtube-dl-gui
deleted file mode 100755
index 2b4e8c7bc354..000000000000
--- a/youtube-dl-gui
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-source /usr/share/youtube-dl-gui/venv/bin/activate
-yt-dlg
-
diff --git a/youtube-dl-gui.desktop b/youtube-dl-gui.desktop
deleted file mode 100644
index 02d4dc7aa503..000000000000
--- a/youtube-dl-gui.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Youtube-dl GUI
-Exec=yt-dlg
-Icon=youtube-dl-gui
-Categories=Network;
-Comment=GUI for youtube-dl downloader