summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD101
-rw-r--r--UNLICENSE24
-rw-r--r--youtube-dl-gui.desktop8
4 files changed, 91 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0eb65347901..fc55cb7fae79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = youtube-dl-gui-git
- pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython
- pkgver = 0.3.8.r447.g182a587
- pkgrel = 2
- url = https://github.com/MrS0m30n3/youtube-dl-gui
+ pkgdesc = Cross platform front-end GUI of the popular youtube-dl written in wxPython
+ pkgver = 1.8.4.r22.g23ccbc4
+ pkgrel = 1
+ url = https://github.com/oleksis/youtube-dl-gui
arch = any
license = custom:UNLICENSE
makedepends = git
- depends = gtk-update-icon-cache
- depends = python2-twodict-git
- depends = wxpython
+ makedepends = python-polib
+ makedepends = python-setuptools
+ depends = python-pypubsub
+ depends = python-wxpython
+ depends = xdg-utils
optdepends = ffmpeg: convert video files to audio-only files
- optdepends = youtube-dl: alternative to the youtube-dl program downloaded by youtube-dl-gui
+ optdepends = youtube-dl: alternative to the program downloaded by youtube-dl-gui
provides = youtube-dl-gui
conflicts = youtube-dl-gui
- source = youtube-dl-gui-git::git+https://github.com/MrS0m30n3/youtube-dl-gui.git
- source = youtube-dl-gui.desktop
- md5sums = SKIP
- md5sums = 298421ed0a9e2c6475e0bb3f86d2d2a7
+ source = youtube-dl-gui-git::git+https://github.com/oleksis/youtube-dl-gui.git
+ sha256sums = SKIP
pkgname = youtube-dl-gui-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 420ba0dc1b39..37e991724d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,93 @@
# Maintainer: willemw <willemw12@gmail.com>
# Contributor: B4SH-B00STER
-_pkgname=youtube-dl-gui
-pkgname=$_pkgname-git
-pkgver=0.3.8.r447.g182a587
-pkgrel=2
-pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython"
+pkgname=youtube-dl-gui-git
+pkgver=1.8.4.r22.g23ccbc4
+pkgrel=1
+pkgdesc="Cross platform front-end GUI of the popular youtube-dl written in wxPython"
arch=('any')
-url="https://github.com/MrS0m30n3/youtube-dl-gui"
+url="https://github.com/oleksis/youtube-dl-gui"
license=('custom:UNLICENSE')
-#depends=('gtk-update-icon-cache' 'python2-twodict' 'wxpython')
-depends=('gtk-update-icon-cache' 'python2-twodict-git' 'wxpython')
+# xdg-utils: xdg-open to open and play a file
+depends=('python-pypubsub' 'python-wxpython' 'xdg-utils')
optdepends=('ffmpeg: convert video files to audio-only files'
- 'youtube-dl: alternative to the youtube-dl program downloaded by youtube-dl-gui')
-makedepends=('git')
-provides=($_pkgname)
-conflicts=($_pkgname)
-source=($pkgname::git+https://github.com/MrS0m30n3/youtube-dl-gui.git
- youtube-dl-gui.desktop)
-md5sums=('SKIP'
- '298421ed0a9e2c6475e0bb3f86d2d2a7')
+ 'youtube-dl: alternative to the program downloaded by youtube-dl-gui')
+makedepends=('git' 'python-polib' 'python-setuptools')
+provides=(${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=($pkgname::git+$url.git)
+sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- install -Dm644 youtube-dl-gui.desktop "$pkgdir/usr/share/applications/youtube-dl-gui.desktop"
+#build() {
+# cd $pkgname
+# python setup.py build build_trans
+#}
+package() {
cd $pkgname
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ python setup.py build_trans install --root="$pkgdir" --optimize=1 # --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ install -Dm644 yt-dlg.desktop -t "$pkgdir/usr/share/applications"
}
+
+
+# # Following the upstream build instructions
+#
+# pkgname=youtube-dl-gui-git
+# pkgver=0
+# pkgrel=1
+# pkgdesc="Cross platform front-end GUI of the popular youtube-dl written in wxPython"
+# arch=('any')
+# url="https://github.com/oleksis/youtube-dl-gui"
+# license=('custom:UNLICENSE')
+# # wxgtk3 is a wxpython dependency (see package python-wxpython)
+# # xdg-utils: xdg-open to open and play a file
+# depends=('wxgtk3' 'xdg-utils')
+# optdepends=('ffmpeg: convert video files to audio-only files'
+# 'youtube-dl: alternative to the program downloaded by youtube-dl-gui')
+# makedepends=('git')
+# provides=(${pkgname%-git})
+# conflicts=(${pkgname%-git})
+# source=($pkgname::git+$url.git youtube-dl-gui)
+# sha256sums=('SKIP' '0')
+#
+# pkgver() {
+# git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+# }
+#
+# #check() {
+# # cd $pkgname
+# #
+# # source venv/bin/activate
+# # make test
+# #}
+#
+# package() {
+# install -Dm755 youtube-dl-gui -t "$pkgdir/usr/bin"
+# install -Dm644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+#
+# cd $pkgname
+#
+# export PIP_CONFIG_FILE=/dev/null
+# export TMPDIR="$srcdir/tmp"
+# export XDG_CACHE_HOME="$srcdir/cache"
+#
+# mkdir -p "$TMPDIR"
+#
+# make clean-requirements
+# make venv
+# source venv/bin/activate
+# make install
+#
+# rm -rf "$TMPDIR"
+#
+# install -dm755 "$pkgdir/usr/share/${pkgname%-git}"
+# cp -a venv "$pkgdir/usr/share/${pkgname%-git}"
+# }
+
diff --git a/UNLICENSE b/UNLICENSE
deleted file mode 100644
index 68a49daad8ff..000000000000
--- a/UNLICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <http://unlicense.org/>
diff --git a/youtube-dl-gui.desktop b/youtube-dl-gui.desktop
deleted file mode 100644
index 04cbdcb81b6c..000000000000
--- a/youtube-dl-gui.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Youtube-dl GUI
-Exec=youtube-dl-gui
-Icon=youtube-dl-gui
-Categories=Network;
-Comment=GUI for youtube-dl downloader