summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 116b0cb7d980..363f7d35754c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = youtube-music-bin
pkgdesc = YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)
pkgver = 1.19.0
- pkgrel = 2
+ pkgrel = 3
url = https://th-ch.github.io/youtube-music
install = youtube-music.install
arch = x86_64
license = MIT
+ makedepends = setconf
depends = gtk3
depends = libsecret
depends = nss
diff --git a/PKGBUILD b/PKGBUILD
index 4e0a57713f3e..e2839b5285d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
# Contributor: Harsh Barsaiyan <hbarsaiyan at gmail dot com>
pkgname=youtube-music-bin
pkgver=1.19.0
-pkgrel=2
+pkgrel=3
pkgdesc="YouTube Music Desktop App bundled with custom plugins (and built-in ad blocker / downloader)"
arch=('x86_64')
url="https://th-ch.github.io/youtube-music"
license=('MIT')
depends=('gtk3' 'libsecret' 'nss')
+makedepends=('setconf')
optdepends=('libnotify: desktop notifications'
'libappindicator-gtk3: tray icon')
provides=("${pkgname%-bin}")
@@ -23,6 +24,8 @@ sha256sums=('f8bebf16cd24463dd830bdf3dbd59cc6a4f44a5422a2b995f1ef8bb260325beb'
package(){
bsdtar xfv data.tar.xz -C "$pkgdir"
+ setconf "$pkgdir/usr/share/applications/${pkgname%-bin}.desktop" Exec "${pkgname%-bin} %U"
+
install -Dm755 "${pkgname%-bin}.sh" "$pkgdir/usr/bin/${pkgname%-bin}"
install -Dm644 license -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"