summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c656f9b5ad0e..fbdde1d3431a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yt-dlp-git
pkgdesc = A youtube-dl fork with additional features and fixes (git)
- pkgver = 2023.07.06.r58.g6014355c6
+ pkgver = 2023.07.06.r143.g5fccabac2
pkgrel = 1
url = https://github.com/yt-dlp/yt-dlp
arch = any
@@ -17,9 +17,15 @@ pkgbase = yt-dlp-git
optdepends = rtmpdump: for rtmp streams support
optdepends = atomicparsley: for embedding thumbnails into m4a files
optdepends = aria2: for using aria2 as external downloader
- optdepends = python-mutagen: For embedding thumbnail in certain formats
- optdepends = python-pycryptodomex: For decrypting AES-128 HLS streams and various other data
- optdepends = python-websockets: For downloading over websocket
+ optdepends = python-mutagen: for embedding thumbnail in certain formats
+ optdepends = python-pycryptodomex: for decrypting AES-128 HLS streams and various other data
+ optdepends = python-websockets: for downloading over websocket
+ optdepends = python-brotli: brotli content encoding support
+ optdepends = python-brotlicffi: brotli content encoding support
+ optdepends = python-xattr: for writing xattr metadata
+ optdepends = python-pyxattr: for writing xattr metadata (alternative option)
+ optdepends = phantomjs: for extractors with javascript code
+ optdepends = python-secretstorage: For -cookies-from-browser to access the GNOME keyring while decrypting cookies of Chromium-based browsers
provides = yt-dlp
conflicts = yt-dlp
source = git+https://github.com/yt-dlp/yt-dlp.git
diff --git a/PKGBUILD b/PKGBUILD
index af0265455f6c..766e325d9f67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: katt <magunasu.b97@gmail.com>
pkgname=yt-dlp-git
-pkgver=2023.07.06.r58.g6014355c6
+pkgver=2023.07.06.r143.g5fccabac2
pkgrel=1
pkgdesc='A youtube-dl fork with additional features and fixes (git)'
arch=(any)
@@ -14,9 +14,15 @@ optdepends=('ffmpeg: for video post-processing'
'rtmpdump: for rtmp streams support'
'atomicparsley: for embedding thumbnails into m4a files'
'aria2: for using aria2 as external downloader'
- 'python-mutagen: For embedding thumbnail in certain formats'
- 'python-pycryptodomex: For decrypting AES-128 HLS streams and various other data'
- 'python-websockets: For downloading over websocket')
+ 'python-mutagen: for embedding thumbnail in certain formats'
+ 'python-pycryptodomex: for decrypting AES-128 HLS streams and various other data'
+ 'python-websockets: for downloading over websocket'
+ 'python-brotli: brotli content encoding support'
+ 'python-brotlicffi: brotli content encoding support'
+ 'python-xattr: for writing xattr metadata'
+ 'python-pyxattr: for writing xattr metadata (alternative option)'
+ 'phantomjs: for extractors with javascript code'
+ 'python-secretstorage: For -cookies-from-browser to access the GNOME keyring while decrypting cookies of Chromium-based browsers')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(git+"${url}".git)