summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa173d30cc4d..ee74c7436fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
# Generated by mksrcinfo v8
-# Thu Sep 14 22:07:17 UTC 2017
+# Wed Dec 20 17:47:47 UTC 2017
pkgbase = yubico-yubioath-desktop
pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
- pkgver = 4.2.0
+ pkgver = 4.3.2
pkgrel = 1
url = https://developers.yubico.com/yubioath-desktop/
- arch = i686
arch = x86_64
- license = GPL
+ license = BSD
makedepends = swig
- makedepends = git
+ makedepends = qt5-svg
+ makedepends = libffi
+ makedepends = openssl
+ makedepends = qt5-base
depends = pcsclite
depends = ccid
depends = python-pyotherside
depends = yubikey-manager
depends = qt5-quickcontrols
conflicts = yubico-yubioath-desktop-git
- source = git+https://github.com/Yubico/yubioath-desktop.git#tag=yubioath-desktop-4.2.0
- source = git+https://github.com/thp/pyotherside.git
- source = git+https://github.com/Yubico/yubikey-manager.git
- source = git+https://github.com/qtproject/qt-solutions
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-4.3.2/yubioath-desktop-4.3.2.tar.gz
+ source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-4.3.2/yubioath-desktop-4.3.2.tar.gz.sig
+ sha256sums = 4119a89af48495498a62623404d663835555e0d24fe76409d949e40d4aa141e9
sha256sums = SKIP
pkgname = yubico-yubioath-desktop
diff --git a/PKGBUILD b/PKGBUILD
index d8221a9a9403..e8a5abcd57b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,31 @@
# Maintainer: tuftedocelot@fastmail.fm
_pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}
-pkgver=4.2.0
+pkgver=4.3.2
pkgrel=1
-_tag="${_pkgname}-${pkgver}"
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
-license=('GPL')
+license=('BSD')
depends=('pcsclite' 'ccid' 'python-pyotherside' 'yubikey-manager' 'qt5-quickcontrols')
-makedepends=('swig' 'git')
-validpgpkeys=('8D0B4EBA9345254BCEC0E843514F078FF4AB24C3') # Dag Heyman <dag@yubico.com>
-source=("git+https://github.com/Yubico/yubioath-desktop.git#tag=${_tag}"
-'git+https://github.com/thp/pyotherside.git'
-'git+https://github.com/Yubico/yubikey-manager.git'
-'git+https://github.com/qtproject/qt-solutions')
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
+makedepends=('swig' 'qt5-svg' 'libffi' 'openssl' 'qt5-base')
+validpgpkeys=('8D0B4EBA9345254BCEC0E843514F078FF4AB24C3' # Dag Heyman <dag@yubico.com>
+ '57A9DEED4C6D962A923BB691816F3ED99921835E' # Emil Lundberg <emil@yubico.com>
+ )
+source=("https://github.com/Yubico/${_pkgname}/releases/download/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz"{,.sig})
+sha256sums=('4119a89af48495498a62623404d663835555e0d24fe76409d949e40d4aa141e9'
'SKIP')
conflicts=('yubico-yubioath-desktop-git')
-prepare() {
- cd "${srcdir}/${_pkgname}"
-
- git config --file=.gitmodules submodule.vendor/pyotherside.url ../pyotherside/
- git config --file=.gitmodules submodule.vendor/yubikey-manager.url ../yubikey-manager/
- git config --file=.gitmodules submodule.ykman-gui/vendor/qt-solutions.url ../qt-solutions/
-
- git submodule init
- git submodule update
-}
-
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" QMAKE_LFLAGS_RELEASE="${LDFLAGS}"
make
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}"
make INSTALL_ROOT="${pkgdir}/" install
install -D -m0644 resources/yubioath-desktop.desktop "${pkgdir}/usr/share/applications/yubioath-desktop.desktop"