summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bdaad22f73c..ee74c7436fa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,26 @@
# Generated by mksrcinfo v8
-# Sat Sep 2 12:30:01 UTC 2017
+# Wed Dec 20 17:47:47 UTC 2017
pkgbase = yubico-yubioath-desktop
pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
- pkgver = 4.1.4
+ pkgver = 4.3.2
pkgrel = 1
url = https://developers.yubico.com/yubioath-desktop/
- arch = i686
arch = x86_64
- license = GPL
+ license = BSD
makedepends = swig
- makedepends = git
+ makedepends = qt5-svg
+ makedepends = libffi
+ makedepends = openssl
+ makedepends = qt5-base
depends = pcsclite
depends = ccid
depends = python-pyotherside
depends = yubikey-manager
depends = qt5-quickcontrols
conflicts = yubico-yubioath-desktop-git
- source = git+https://github.com/Yubico/yubioath-desktop.git#tag=yubioath-desktop-4.1.4
- source = git+https://github.com/thp/pyotherside.git
- source = git+https://github.com/Yubico/yubikey-manager.git
- source = git+https://github.com/qtproject/qt-solutions
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-4.3.2/yubioath-desktop-4.3.2.tar.gz
+ source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-4.3.2/yubioath-desktop-4.3.2.tar.gz.sig
+ sha256sums = 4119a89af48495498a62623404d663835555e0d24fe76409d949e40d4aa141e9
sha256sums = SKIP
pkgname = yubico-yubioath-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 7f0aedb0e5ca..79d5f972a1d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,31 @@ _pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}
pkgver=4.3.3
pkgrel=1
-_tag="${_pkgname}-${pkgver}"
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
-license=('GPL')
-depends=('pcsclite' 'ccid' 'python-pyotherside' 'yubikey-manager' 'qt5-quickcontrols')
-makedepends=('swig' 'git')
-validpgpkeys=('8D0B4EBA9345254BCEC0E843514F078FF4AB24C3') # Dag Heyman <dag@yubico.com>
+license=('BSD')
+depends=('pcsclite' 'ccid' 'python-pyotherside' 'yubikey-manager>=0.6.0' 'qt5-quickcontrols')
+makedepends=('swig' 'qt5-svg' 'libffi' 'openssl' 'qt5-base')
+validpgpkeys=('8D0B4EBA9345254BCEC0E843514F078FF4AB24C3' # Dag Heyman <dag@yubico.com>
+ '57A9DEED4C6D962A923BB691816F3ED99921835E' # Emil Lundberg <emil@yubico.com>
+ )
source=("https://github.com/Yubico/${_pkgname}/releases/download/${_pkgname}-${pkgver}/${_pkgname}-${pkgver}.tar.gz"{,.sig})
-md5sums=('942480b432f3985b5ba9b57c928936dc'
- 'SKIP')
+sha256sums=('fec3bacf05470dc119b4ec4c077ed13b49c9052baffd98dbcd9a3f05635b0aa8'
+ 'SKIP')
conflicts=('yubico-yubioath-desktop-git')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" QMAKE_LFLAGS_RELEASE="${LDFLAGS}"
make
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_pkgname}-${pkgver}"
make INSTALL_ROOT="${pkgdir}/" install
- install -D -m0644 resources/yubioath.desktop "${pkgdir}/usr/share/applications/yubioath.desktop"
+ install -D -m0644 resources/yubioath-desktop.desktop "${pkgdir}/usr/share/applications/yubioath-desktop.desktop"
install -D -m0644 resources/icons/yubioath.png "${pkgdir}/usr/share/pixmaps/yubioath.png"
}