summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f898f6887d0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = yubico-yubioath-desktop
+ pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://developers.yubico.com/yubioath-desktop/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python2-pyside
+ makedepends = python2-pyscard-svn
+ makedepends = python2-pbkdf2
+ makedepends = python2-setuptools
+ depends = python2
+ depends = pcsclite
+ depends = ccid
+ source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-2.1.1/yubioath-desktop-2.1.1.tar.gz
+ sha256sums = 8d4243311d7cbd08970d81e38616f90b851fa73939bf7ffaa91fe5c2aa2025d5
+
+pkgname = yubico-yubioath-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9592a83e8501
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: tuftedocelot@fastmail.fm
+_pkgname=yubioath-desktop
+pkgname=yubico-${_pkgname}
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
+arch=('i686' 'x86_64')
+url="https://developers.yubico.com/yubioath-desktop/"
+license=('GPL')
+depends=('python2' 'pcsclite' 'ccid')
+makedepends=('git' 'python2-pyside' 'python2-pyscard-svn' 'python2-pbkdf2' 'python2-setuptools')
+source="https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-2.1.1/yubioath-desktop-2.1.1.tar.gz"
+sha256sums=('8d4243311d7cbd08970d81e38616f90b851fa73939bf7ffaa91fe5c2aa2025d5')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+
+ cat >> "$pkgdir/usr/bin/yubicoauthenticator" <<EOF
+#!/bin/sh
+python2 /usr/lib/python2.7/site-packages/yubicoauthenticator/yubico_authenticator.py
+EOF
+ chmod +x "$pkgdir/usr/bin/yubicoauthenticator"
+
+
+ cat >> "$pkgdir/usr/bin/yubicoauthenticator-disable-systray" <<EOF
+#!/bin/sh
+python2 /usr/lib/python2.7/site-packages/yubicoauthenticator/yubico_authenticator.py --disable-systray
+EOF
+ chmod +x "$pkgdir/usr/bin/yubicoauthenticator-disable-systray"
+
+ cd "${srcdir}/$_pkgname-${pkgver}"
+ python2 setup.py install --root=${pkgdir}
+
+ mkdir -p ${pkgdir}/usr/share/applications/
+ install -D -m0644 ${srcdir}/$_pkgname-${pkgver}/resources/yubioath.desktop ${pkgdir}/usr/share/applications/
+ mkdir -p ${pkgdir}/usr/share/pixmaps
+ install -D -m0644 ${srcdir}/$_pkgname-${pkgver}/resources/yubioath.xpm ${pkgdir}/usr/share/pixmaps
+}