summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c72fb10dbc0b..82afd5f00969 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Thu Mar 16 23:27:08 UTC 2017
+# Sat Apr 15 13:06:50 UTC 2017
pkgbase = yubico-yubioath-desktop
pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
- pkgver = 3.1.0
- pkgrel = 2
+ pkgver = 4.1.0
+ pkgrel = 1
url = https://developers.yubico.com/yubioath-desktop/
arch = i686
arch = x86_64
license = GPL
+ depends = yubikey-manager
depends = pcsclite
depends = ccid
depends = python-pyside
@@ -18,9 +19,11 @@ pkgbase = yubico-yubioath-desktop
depends = python-crypto
depends = yubikey-personalization
depends = python-click
+ depends = python-pyotherside
+ depends = qt-solutions-git
conflicts = yubico-yubioath-desktop-git
- source = https://github.com/Yubico/yubioath-desktop/releases/download/yubioath-desktop-3.1.0/yubioath-desktop-3.1.0.tar.gz
- sha256sums = 7caae0fd3b14529476eda3a5660bc050584b298ddc3c8d1adfe221041fa5db49
+ source = git://github.com/Yubico/yubioath-desktop.git#tag=yubioath-desktop-4.1.0
+ sha256sums = SKIP
pkgname = yubico-yubioath-desktop
diff --git a/PKGBUILD b/PKGBUILD
index f0ef635d46e9..0b6b7243ce8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,35 @@
# Maintainer: tuftedocelot@fastmail.fm
_pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}
-pkgver=3.1.0
-pkgrel=2
+pkgver=4.1.0
+pkgrel=1
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
arch=('i686' 'x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
license=('GPL')
-depends=('pcsclite' 'ccid' 'python-pyside' 'python-pyscard' 'python-pbkdf2' 'python-setuptools' 'python-pyside-tools' 'python-crypto' 'yubikey-personalization' 'python-click')
-source=("https://github.com/Yubico/yubioath-desktop/releases/download/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz")
-sha256sums=('7caae0fd3b14529476eda3a5660bc050584b298ddc3c8d1adfe221041fa5db49')
+depends=('yubikey-manager' 'pcsclite' 'ccid' 'python-pyside' 'python-pyscard'
+'python-pbkdf2' 'python-setuptools' 'python-pyside-tools' 'python-crypto'
+'yubikey-personalization' 'python-click' 'python-pyotherside' 'qt-solutions-git')
+source=("git://github.com/Yubico/yubioath-desktop.git#tag=yubioath-desktop-4.1.0")
+sha256sums=('SKIP')
conflicts=('yubico-yubioath-desktop-git')
+prepare() {
+ cd "${srcdir}/$_pkgname"
+ git submodule init
+ git submodule update
+}
+
package() {
mkdir -p ${pkgdir}/usr/bin
- cd "${srcdir}/$_pkgname-${pkgver}"
- python setup.py install --root=${pkgdir}
+ cd "${srcdir}/$_pkgname"
+ qmake
+ make
+ install -D -m0755 ${srcdir}/yubioath-desktop/yubioath-desktop ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/share/applications/
- install -D -m0644 ${srcdir}/$_pkgname-${pkgver}/resources/yubioath.desktop ${pkgdir}/usr/share/applications/
- mkdir -p ${pkgdir}/usr/share/pixmaps
- install -D -m0644 ${srcdir}/$_pkgname-${pkgver}/resources/yubioath.xpm ${pkgdir}/usr/share/pixmaps
+ mkdir -p ${pkgdir}/usr/share/icons/
+ install -D -m0644 ${srcdir}/$_pkgname/resources/yubioath.desktop ${pkgdir}/usr/share/applications/
+ install -D -m0644 ${srcdir}/$_pkgname/resources/icons/yubioath.png ${pkgdir}/usr/share/icons/
}