summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD77
2 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4927620c2f4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = yuzu-canary-git
+ pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
+ pkgver = r7568.b906f0f5
+ pkgrel = 1
+ url = https://github.com/yuzu-emu/yuzu-canary
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ depends = sdl2
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = mbedtls
+ optdepends = libxkbcommon-x11: for X11 support
+ optdepends = qt5-wayland: for Wayland support
+ source = yuzu::git+https://github.com/yuzu-emu/yuzu-canary
+ source = git+https://github.com/svn2github/inih
+ source = git+https://github.com/yuzu-emu/ext-boost
+ source = git+https://github.com/philsquared/Catch
+ source = git+https://github.com/kinetiknz/cubeb
+ source = git+https://github.com/MerryMage/dynarmic
+ source = git+https://github.com/herumi/xbyak
+ source = git+https://github.com/fmtlib/fmt
+ source = git+https://github.com/lz4/lz4
+ source = git+https://github.com/yuzu-emu/unicorn
+ source = git+https://github.com/ogniK5377/opus
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = yuzu-canary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..558a1f89cd63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Brendan Szymanski <brendan.szymanski1@gmail.com>
+
+_pkgname=yuzu
+pkgname=$_pkgname-canary-git
+pkgver=r7568.b906f0f5
+pkgrel=1
+pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
+arch=('i686' 'x86_64')
+url="https://github.com/yuzu-emu/yuzu-canary"
+license=('GPL2')
+depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'mbedtls')
+makedepends=('git' 'cmake')
+optdepends=('libxkbcommon-x11: for X11 support'
+ 'qt5-wayland: for Wayland support')
+source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
+ 'git+https://github.com/svn2github/inih'
+ 'git+https://github.com/yuzu-emu/ext-boost'
+ 'git+https://github.com/philsquared/Catch'
+ 'git+https://github.com/kinetiknz/cubeb'
+ 'git+https://github.com/MerryMage/dynarmic'
+ 'git+https://github.com/herumi/xbyak'
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/lz4/lz4'
+ 'git+https://github.com/yuzu-emu/unicorn'
+ 'git+https://github.com/ogniK5377/opus')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+
+ git submodule init
+ git config submodule.inih.url "$srcdir/inih"
+ git config submodule.boost.url "$srcdir/ext-boost"
+ git config submodule.catch.url "$srcdir/Catch"
+ git config submodule.cubeb.url "$srcdir/cubeb"
+ git config submodule.dynarmic.url "$srcdir/dynarmic"
+ git config submodule.xbyak.url "$srcdir/xbyak"
+ git config submodule.fmt.url "$srcdir/fmt"
+ git config submodule.lz4.url "$srcdir/lz4"
+ git config submodule.unicorn.url "$srcdir/unicorn"
+ git config submodule.opus.url "$srcdir/opus"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_CURL=1
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname/build"
+ make test
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/build/bin/${_pkgname}-cmd" "$pkgdir/usr/bin/${_pkgname}-cmd"
+}