summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a6e11f53d3f..15f3da718052 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r17729.2ff39f6fd
+ pkgver = r18480.e7c30f33f
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
@@ -37,7 +37,7 @@ pkgbase = yuzu-git
source = git+https://github.com/citra-emu/ext-soundtouch.git
source = libressl::git+https://github.com/citra-emu/ext-libressl-portable.git
source = git+https://github.com/libusb/libusb.git
- source = git+https://github.com/discordapp/discord-rpc.git
+ source = git+https://github.com/discord/discord-rpc.git
source = git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/ReinUsesLisp/sirit
source = git+https://github.com/yuzu-emu/mbedtls
@@ -46,6 +46,7 @@ pkgbase = yuzu-git
source = git+https://github.com/xiph/opus.git
source = git+https://git.ffmpeg.org/ffmpeg.git
source = git+https://github.com/libsdl-org/SDL.git
+ source = git+https://github.com/yhirose/cpp-httplib.git
source = git+https://github.com/arsenm/sanitizers-cmake.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
md5sums = SKIP
@@ -66,6 +67,6 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e022bad28739..e7a824c3d32c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r17729.2ff39f6fd
+pkgver=r18480.e7c30f33f
pkgrel=1
pkgdesc='An experimental open-source Nintendo Switch emulator/debugger'
arch=('i686' 'x86_64')
@@ -34,7 +34,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/citra-emu/ext-soundtouch.git'
'libressl::git+https://github.com/citra-emu/ext-libressl-portable.git'
'git+https://github.com/libusb/libusb.git'
- 'git+https://github.com/discordapp/discord-rpc.git'
+ 'git+https://github.com/discord/discord-rpc.git'
'git+https://github.com/KhronosGroup/Vulkan-Headers.git'
'git+https://github.com/ReinUsesLisp/sirit'
'git+https://github.com/yuzu-emu/mbedtls'
@@ -43,6 +43,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/xiph/opus.git'
'git+https://git.ffmpeg.org/ffmpeg.git'
'git+https://github.com/libsdl-org/SDL.git'
+ 'git+https://github.com/yhirose/cpp-httplib.git'
# cubeb dependencies
'git+https://github.com/arsenm/sanitizers-cmake.git'
# sirit dependencies
@@ -64,6 +65,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -74,7 +76,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL}; do
+ for submodule in externals/{inih/inih,cubeb,dynarmic,soundtouch,libressl,libusb/libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,libzip/libzip,xbyak,opus/opus,ffmpeg,SDL,cpp-httplib}; do
git submodule init ${submodule}
git config submodule.${submodule}.url "$srcdir/${submodule##*/}"
git submodule update