summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--install9
-rwxr-xr-xz-push-admin2
-rwxr-xr-xz-push-top2
5 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 415933c5a606..e773ef54caea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Dec 1 01:04:22 UTC 2015
+# Tue Dec 1 16:43:27 UTC 2015
pkgbase = z-push
pkgdesc = open-source implementation of the ActiveSync protocol
pkgver = 2.2.5
- pkgrel = 4
+ pkgrel = 6
url = http://z-push.sf.net/
install = install
arch = any
@@ -25,6 +25,8 @@ pkgbase = z-push
source = nginx-location.conf
source = nginx-ssl.example.conf
source = php-fpm.example.conf
+ source = z-push-admin
+ source = z-push-top
md5sums = 4a89b1a827ab7019d41e42179fc83094
md5sums = 32a459bd61135b6c5e99e82e3a6b0007
md5sums = 1091aa1ba272ef05bf628f73b05c527a
@@ -33,6 +35,8 @@ pkgbase = z-push
md5sums = 9637d4164f85cb3fb9a886654645a46c
md5sums = 1bdab5b1e4473c1b0f6ce2e5c8f1da61
md5sums = 7adcf5e023718421a5e8e07e5e9a2480
+ md5sums = 626a81889bebd6184d8f90deb00f6119
+ md5sums = dfa0d3eceef2433ded6229b6611c5e02
pkgname = z-push
diff --git a/PKGBUILD b/PKGBUILD
index b96ee01c6fcb..7d1228f71d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=z-push
pkgver=2.2.5
-pkgrel=4
+pkgrel=6
pkgdesc="open-source implementation of the ActiveSync protocol"
arch=('any')
url="http://z-push.sf.net/"
@@ -26,7 +26,9 @@ source=("${pkgname}-${pkgver}.tar.gz::http://download.z-push.org/final/2.2/${pkg
"z-push.conf"
"nginx-location.conf"
"nginx-ssl.example.conf"
- "php-fpm.example.conf")
+ "php-fpm.example.conf"
+ "z-push-admin"
+ "z-push-top")
md5sums=('4a89b1a827ab7019d41e42179fc83094'
'32a459bd61135b6c5e99e82e3a6b0007'
@@ -35,7 +37,9 @@ md5sums=('4a89b1a827ab7019d41e42179fc83094'
'b61c194ee4e3e3bf8bfa6a72e6f38019'
'9637d4164f85cb3fb9a886654645a46c'
'1bdab5b1e4473c1b0f6ce2e5c8f1da61'
- '7adcf5e023718421a5e8e07e5e9a2480')
+ '7adcf5e023718421a5e8e07e5e9a2480'
+ '626a81889bebd6184d8f90deb00f6119'
+ 'dfa0d3eceef2433ded6229b6611c5e02')
package() {
# according to https://wiki.archlinux.org/index.php/Web_application_package_guidelines
@@ -45,8 +49,8 @@ package() {
rm ${pkgdir}/usr/share/webapps/z-push/config.php
mkdir -p ${pkgdir}/usr/bin
- ln -s /usr/share/webapps/z-push/z-push-admin.php ${pkgdir}/usr/bin/z-push-admin
- ln -s /usr/share/webapps/z-push/z-push-top.php ${pkgdir}/usr/bin/z-push-top
+ cp ${srcdir}/z-push-admin ${pkgdir}/usr/bin
+ cp ${srcdir}/z-push-top ${pkgdir}/usr/bin
mkdir -p ${pkgdir}/etc/webapps/z-push
cp ${srcdir}/apache.example.conf ${pkgdir}/etc/webapps/z-push/
diff --git a/install b/install
index 9152473a60d7..399f8dfb9f3f 100644
--- a/install
+++ b/install
@@ -1,12 +1,9 @@
post_install() {
cp -n /etc/webapps/z-push/config.example.php /etc/webapps/z-push/config.php
- if [[ ! -e /var/lib/z-push ]];
- then
- mkdir -p /var/lib/z-push
- chown -R http:http /var/lib/z-push
- fi
-
+ mkdir -p /var/lib/z-push
+
+ chown -R http:http /var/lib/z-push
chown -R http:http /var/log/z-push
}
diff --git a/z-push-admin b/z-push-admin
new file mode 100755
index 000000000000..ed9bde2900fa
--- /dev/null
+++ b/z-push-admin
@@ -0,0 +1,2 @@
+#!/bin/bash
+/usr/share/webapps/z-push/z-push-admin.php "$@" \ No newline at end of file
diff --git a/z-push-top b/z-push-top
new file mode 100755
index 000000000000..bb9ce296be82
--- /dev/null
+++ b/z-push-top
@@ -0,0 +1,2 @@
+#!/bin/bash
+/usr/share/webapps/z-push/z-push-top.php "$@" \ No newline at end of file