summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--fix-makefile.patch54
3 files changed, 81 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 509a1b357871..f3d302a4d83f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = z88dk
- pkgdesc = A small C compiler for the Zilog Z80.
- pkgver = 1.99B
- pkgrel = 2
+ pkgdesc = Developement kit for Z80 computers
+ pkgver = 1.99C
+ pkgrel = 1
url = http://z88dk.org
arch = i686
arch = x86_64
license = custom:The Clarified Artistic License
depends = perl
+ depends = libxml2
backup = etc/profile.d/z88dk.sh
- source = http://downloads.sourceforge.net/project/z88dk/z88dk/1.99B/z88dk-src-1.99B.zip
- source = fix-build.patch
+ source = http://downloads.sourceforge.net/project/z88dk/z88dk/1.99C/z88dk-src-1.99C.tgz
+ source = fix-makefile.patch
source = z88dk.sh
- md5sums = 6412a730d1b38a8ecf393683981a33ae
- md5sums = 187b8002f426323f603f654cfe47307d
- md5sums = a7d56837ef0cc9fbb05d2e21ddcc335c
+ sha256sums = f60932517116195993236cf28668522a3cbd19409cb430030754c7f0c0cb3a77
+ sha256sums = 78aaeb862a714c632e7ed16872ada2c4e246291be716ddb1e7613a2d28405e5c
+ sha256sums = 4eef7c67e5b142db3006a4076876cdae9f386a7b94a66841a5a8fac869bea156
pkgname = z88dk
diff --git a/PKGBUILD b/PKGBUILD
index 4083f969c2ca..39f70f09041f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Ábel Futó <lebaotuf+arch at gmail dot com>
# Contributor: John Schug <xtr.xtrnet@gmail.com>
pkgname=z88dk
-pkgver=1.99B
-#_pkgver=1.99A
-pkgrel=2
-pkgdesc="A small C compiler for the Zilog Z80."
+pkgver=1.99C
+pkgrel=1
+pkgdesc="Developement kit for Z80 computers"
arch=('i686' 'x86_64')
url="http://z88dk.org"
license=('custom:The Clarified Artistic License')
-depends=('perl')
+depends=('perl' 'libxml2')
backup=(etc/profile.d/z88dk.sh)
-source=(http://downloads.sourceforge.net/project/z88dk/z88dk/${pkgver}/${pkgname}-src-${pkgver}.zip
- fix-build.patch
+source=(http://downloads.sourceforge.net/project/z88dk/z88dk/${pkgver}/${pkgname}-src-${pkgver}.tgz
+ fix-makefile.patch
z88dk.sh)
-md5sums=('6412a730d1b38a8ecf393683981a33ae'
- '187b8002f426323f603f654cfe47307d'
- 'a7d56837ef0cc9fbb05d2e21ddcc335c')
+sha256sums=('f60932517116195993236cf28668522a3cbd19409cb430030754c7f0c0cb3a77'
+ '78aaeb862a714c632e7ed16872ada2c4e246291be716ddb1e7613a2d28405e5c'
+ '4eef7c67e5b142db3006a4076876cdae9f386a7b94a66841a5a8fac869bea156')
prepare() {
cd "${srcdir}/${pkgname}"
- patch -Np1 < ../fix-build.patch
- chmod +x config.sh build.sh
+ patch -Np1 < ../fix-makefile.patch
+
}
build() {
@@ -38,13 +37,17 @@ build() {
package() {
cd "${srcdir}/${pkgname}"
make prefix="/usr" DESTDIR="${pkgdir}" install
- make prefix="/usr" DESTDIR="${pkgdir}" install-libs
install -dm755 ${pkgdir}/etc/profile.d/
install -m755 ${srcdir}/z88dk.sh ${pkgdir}/etc/profile.d/
# Include docs
- install -dm755 ${pkgdir}/usr/share/doc/${pkgname}/
- find doc/* -not \( -path doc/CVS -prune \) -not \( -path doc/netman -prune \) | xargs -i install -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}"
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}/images
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}/resources
+ find doc/* -not \( -path doc/netman -prune \) -not \( -path doc/images -prune \) \
+ -not \( -path doc/resources -prune \) | xargs -i install -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}"
+ find doc/images/* | xargs -i install -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}/images"
+ find doc/resources/* | xargs -i install -m644 "{}" "${pkgdir}/usr/share/doc/${pkgname}/resources"
# License
install -D -m755 LICENSE "${pkgdir}/usr/share/licenses/z88dk/LICENSE"
}
diff --git a/fix-makefile.patch b/fix-makefile.patch
new file mode 100644
index 000000000000..af865b9359d5
--- /dev/null
+++ b/fix-makefile.patch
@@ -0,0 +1,54 @@
+diff -Naur z88dk.old/Makefile z88dk/Makefile
+--- z88dk.old/Makefile 2018-09-06 05:00:11.000000000 +0200
++++ z88dk/Makefile 2019-02-09 12:59:16.622305360 +0100
+@@ -25,11 +25,6 @@
+ EXEC_PREFIX ?=
+ CROSS ?= 0
+
+-ifneq (, $(shell which ccache))
+- OCC := $(CC)
+- CC := ccache $(CC)
+-endif
+-
+ SDCC_PATH = /tmp/sdcc
+ Z88DK_PATH = $(shell pwd)
+
+@@ -38,7 +33,7 @@
+ export CC INSTALL CFLAGS EXEC_PREFIX CROSS
+
+ all: setup appmake copt zcpp ucpp sccz80 z80asm zcc zpragma zx7 z80nm zobjcopy \
+- lstmanip ticks z80svg font2pv1000 testsuite z88dk-lib zsdcc
++ lstmanip ticks z80svg font2pv1000 testsuite z88dk-lib
+
+ setup:
+ $(shell if [ "${git_count}" != "" ]; then \
+@@ -64,9 +59,9 @@
+ --disable-avr-port --disable-ds390-port \
+ --disable-ds400-port --disable-hc08-port \
+ --disable-pic-port --disable-pic14-port \
+- --disable-pic16-port --disable-stm8-port \
++ --disable-pic16-port --disable-stm8-port \
+ --disable-tlcs90-port --disable-s08-port \
+- --disable-ucsim --disable-device-lib \
++ --disable-ucsim --disable-device-lib \
+ --disable-packihx
+ cd $(SDCC_PATH) && $(MAKE)
+ cd $(SDCC_PATH) && mv ./bin/sdcc $(Z88DK_PATH)/bin/zsdcc
+@@ -143,7 +138,7 @@
+ cd libsrc ; $(MAKE) install
+
+ install: install-clean
+- install -d $(DESTDIR)/$(prefix) $(DESTDIR)/$(prefix_share)/lib
++ install -d $(DESTDIR)/$(prefix) $(DESTDIR)/$(prefix)/bin $(DESTDIR)/$(prefix_share)/lib
+ $(MAKE) -C src/appmake PREFIX=$(DESTDIR)/$(prefix) install
+ $(MAKE) -C src/copt PREFIX=$(DESTDIR)/$(prefix) install
+ $(MAKE) -C src/ucpp PREFIX=$(DESTDIR)/$(prefix) install
+@@ -204,6 +199,7 @@
+ $(MAKE) -C test clean
+ $(MAKE) -C testsuite clean
+ $(MAKE) -C src/z88dk-lib clean
+- #if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
++# if [ -d bin ]; then find bin -type f -exec rm -f {} ';' ; fi
+
+ .PHONY: test testsuite
++