summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index 8de5205378c0..7d8bd890de06 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@
*.xz
*~
/zam-plugins-git/
+/dpf/
diff --git a/PKGBUILD b/PKGBUILD
index 5029d3d30bf3..8c89403584e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer Haskellfant <moritz.kiefer@purelyfunctional.org
pkgname=zam-plugins-git
-pkgver=3.4.r0.gc0b5904
-pkgrel=2
+pkgver=3.5.r84.g922601d
+pkgrel=1
pkgdesc="Collection of LV2/LADSPA/VST audio plugins for high quality processing"
arch=('i686' 'x86_64')
url="https://github.com/zamaudio/zam-plugins"
@@ -10,14 +10,23 @@ provides=('zamplugins')
depends=('gcc-libs')
makedepends=('git' 'pkg-config' 'libx11' 'libgl' 'liblo' 'jack' 'ladspa')
optdepends=()
-source=("$pkgname"::'git://github.com/zamaudio/zam-plugins.git')
-md5sums=('SKIP')
+source=("$pkgname"::'git://github.com/zamaudio/zam-plugins.git'
+ "dpf"::'git://github.com/DISTRHO/DPF.git')
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "$srcdir/$pkgname"
git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.dpf.url "$srcdir/dpf"
+ git submodule update
+}
+
build() {
cd "$srcdir/$pkgname"
make