summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD37
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 549ab530eee4..b0b1cb5cb481 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = zchunk
- pkgdesc = A file format that allows easy deltas while maintaining good compression
- pkgver = 1.1.2
+ pkgdesc = A file format designed for highly efficient deltas while maintaining good compression
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/zchunk/zchunk
- arch = x86
arch = x86_64
license = BSD
makedepends = meson
depends = libcurl.so
depends = zstd
provides = libzck.so
- source = zchunk-1.1.2.tar.gz::https://github.com/zchunk/zchunk/archive/1.1.2.tar.gz
- sha256sums = dcd7389ab9f947a53c83e32e842ba6ef69f931836bba585617a2bb7ec3cf900f
+ source = zchunk-1.3.0.tar.gz::https://github.com/zchunk/zchunk/archive/1.3.0.tar.gz
+ sha256sums = 5563baa254b256e30e1fea87f94f53a5cf63a074898644f3f7ae5b58f446db03
pkgname = zchunk
-
diff --git a/PKGBUILD b/PKGBUILD
index 4af6d9119e6d..a282916e1204 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
-# Maintainer: Nikita Puzyryov <PuzyryovN@gmail.com>
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+# Ex-Maintainer: Nikita Puzyryov <PuzyryovN@gmail.com>
+#
+# PRs are welcome here: https://github.com/yurikoles-aur/zchunk
+#
+
pkgname=zchunk
-pkgver=1.1.2
+pkgver=1.3.0
pkgrel=1
-pkgdesc="A file format that allows easy deltas while maintaining good compression"
-arch=(x86 x86_64)
-url="https://github.com/zchunk/zchunk"
-license=('BSD')
-depends=('libcurl.so' 'zstd')
-provides=('libzck.so')
-makedepends=('meson')
+pkgdesc='A file format designed for highly efficient deltas while maintaining good compression'
+arch=(x86_64)
+url=https://github.com/zchunk/zchunk
+license=(BSD)
+depends=(libcurl.so zstd)
+provides=(libzck.so)
+makedepends=(meson)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('dcd7389ab9f947a53c83e32e842ba6ef69f931836bba585617a2bb7ec3cf900f')
+sha256sums=('5563baa254b256e30e1fea87f94f53a5cf63a074898644f3f7ae5b58f446db03')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- arch-meson build/
- ninja -C build/
+ arch-meson "${pkgname}-${pkgver}" build
+ meson compile -C build
}
check() {
- cd "$srcdir/$pkgname-$pkgver/build"
- meson test
+ meson test -C build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- DESTDIR="$pkgdir/" ninja -C build/ install
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}