summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
-rw-r--r--zecwallet-icons.tar.xzbin0 -> 99180 bytes
-rw-r--r--zecwallet-lite.desktop13
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..600ae5135a76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = zecwallet-lite
+ pkgdesc = A z-Addr first lightwallet for Zcash.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/adityapk00/zecwallet-lite
+ arch = any
+ license = MIT
+ makedepends = rust
+ makedepends = nodejs
+ makedepends = yarn
+ depends = electron
+ provides = zcash-wallet
+ options = !strip
+ source = zecwallet-lite-1.2.0.tar.gz::https://github.com/adityapk00/zecwallet-lite/archive/v1.2.0.tar.gz
+ source = zecwallet-icons.tar.xz
+ source = zecwallet-lite.desktop
+ sha256sums = cb015d0f6ed919314c920ecbb641791fdb6d4167d3913e19d555022fa2920fab
+ sha256sums = 19d8b4acee2c6ff062e86ecbb2365123d0471f2991192323780b53630104574d
+ sha256sums = a53083250c61d1e43cf3b5c371222bb5740e2befcdc4d9b7ea003a1f4ac30ef4
+
+pkgname = zecwallet-lite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7fba741e78d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: GI Jack <GI_Jack@hackermail.com>
+pkgname=zecwallet-lite
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A z-Addr first lightwallet for Zcash."
+arch=('any')
+url="https://github.com/adityapk00/zecwallet-lite"
+license=('MIT')
+depends=('electron')
+makedepends=('rust' 'nodejs' 'yarn')
+provides=('zcash-wallet')
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/adityapk00/zecwallet-lite/archive/v${pkgver}.tar.gz"
+ "zecwallet-icons.tar.xz"
+ "${pkgname}.desktop")
+noextract=()
+sha256sums=('cb015d0f6ed919314c920ecbb641791fdb6d4167d3913e19d555022fa2920fab'
+ '19d8b4acee2c6ff062e86ecbb2365123d0471f2991192323780b53630104574d'
+ 'a53083250c61d1e43cf3b5c371222bb5740e2befcdc4d9b7ea003a1f4ac30ef4')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ yarn install
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ #yarn build --linux
+ yarn package-linux
+}
+
+package() {
+ cd ${srcdir}
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ cd "${pkgname}-${pkgver}"
+ install -d "${pkgdir}/opt/${pkgname}/"
+ cp -ra release/linux-unpacked/* "${pkgdir}/opt/${pkgname}/"
+ cd ..
+
+ # Icons
+ cd ${srcdir}/zecwallet-icons
+ resolutions="16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024"
+ for res in ${resolutions};do
+ install -Dm644 "${res}/apps/zecwallet-lite.png" "${pkgdir}/usr/share/icons/hicolor/${res}/apps/zecwallet-lite.png"
+ done
+}
diff --git a/zecwallet-icons.tar.xz b/zecwallet-icons.tar.xz
new file mode 100644
index 000000000000..c20c6d4c7332
--- /dev/null
+++ b/zecwallet-icons.tar.xz
Binary files differ
diff --git a/zecwallet-lite.desktop b/zecwallet-lite.desktop
new file mode 100644
index 000000000000..3d8bf9796d69
--- /dev/null
+++ b/zecwallet-lite.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=ZecWallet Lite
+Exec=/opt/zecwallet-lite/zecwallet-lite %U
+Terminal=false
+Type=Application
+Icon=zecwallet-lite
+StartupWMClass=zecwalletlite
+Comment=Zecwallet Lite
+GenericName=Zcash Wallet
+StartupNotify=true
+Categories=Network;Cryptocurrency;
+MimeType=x-scheme-handler/zcash;
+Keywords=zecwallet;