summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9690c00d26c9..961b172efa19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zed
pkgdesc = Tooling for super-structured data
pkgver = 1.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://zed.brimdata.io/
arch = x86_64
license = BSD
@@ -9,8 +9,8 @@ pkgbase = zed
makedepends = go
depends = glibc
options = !lto
- source = zed::git+https://github.com/brimdata/zed#commit=357cae73e0fa3713258bdfa8517071ff2ebf7fb4
- md5sums = SKIP
+ source = zed::git+https://github.com/brimdata/zed#tag=v1.14.0
+ sha256sums = c48145e4239de74fe9864974122d66b3b798715dc85858dd4671f4376788df8f
pkgname = zed
diff --git a/PKGBUILD b/PKGBUILD
index 8d1ecf22ca54..0a3b1952d1e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,7 @@ pkgname=(
'zq'
)
pkgver=1.14.0
-_commit='357cae73e0fa3713258bdfa8517071ff2ebf7fb4'
-pkgrel=1
+pkgrel=2
pkgdesc='Tooling for super-structured data'
arch=('x86_64')
url='https://zed.brimdata.io/'
@@ -16,18 +15,8 @@ license=('BSD')
depends=('glibc')
makedepends=('git' 'go')
options=('!lto')
-source=("$pkgbase::git+https://github.com/brimdata/zed#commit=$_commit")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$pkgbase"
-
- git describe --tags | sed 's/^v//'
-}
-
-_pkgver() {
- curl -fs https://api.github.com/repos/brimdata/$pkgname/git/ref/tags/v$pkgver | jq -r .object.sha
-}
+source=("$pkgbase::git+https://github.com/brimdata/zed#tag=v$pkgver")
+sha256sums=('c48145e4239de74fe9864974122d66b3b798715dc85858dd4671f4376788df8f')
prepare() {
cd "$pkgbase"
@@ -51,7 +40,7 @@ build() {
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags ${LDFLAGS} \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" \
-X github.com/brimdata/zed/cli.Version=$pkgver" \
-o dist \
./cmd/{zed,zq}