summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e648f4f55c8..20d0b8899407 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zellij-selector
pkgdesc = Select zellij session
- pkgver = 1.2.2
- pkgrel = 3
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://git.stefanwimmer128.eu/stefanwimmer128/zellij-selector
arch = any
license = MPL2
@@ -11,10 +11,11 @@ pkgbase = zellij-selector
depends = sh
depends = libnewt
depends = zellij
+ depends = jq
optdepends = fish: Option to option fish shell
optdepends = zsh: Option to open zsh shell
optdepends = bash: Option to open bash shell
- source = zellij-selector::git+https://git.stefanwimmer128.eu/stefanwimmer128/zellij-selector.git#tag=v1.2.2
+ source = zellij-selector::git+https://git.stefanwimmer128.eu/stefanwimmer128/zellij-selector.git#tag=v2.0.0
sha256sums = SKIP
pkgname = zellij-selector
diff --git a/PKGBUILD b/PKGBUILD
index ca161977c5b6..5fb4212fcff4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: stefanwimmer128 <info at stefanwimmer128 dot eu>
pkgname='zellij-selector'
-pkgver='1.2.2'
-pkgrel='3'
+pkgver='2.0.0'
+pkgrel='1'
pkgdesc='Select zellij session'
arch=('any')
url='https://git.stefanwimmer128.eu/stefanwimmer128/zellij-selector'
license=('MPL2')
-depends=('sh' 'libnewt' 'zellij')
+depends=('sh' 'libnewt' 'zellij' 'jq')
makedepends=('make' 'git' 'shellcheck')
optdepends=('fish: Option to option fish shell'
'zsh: Option to open zsh shell'
@@ -15,12 +15,6 @@ optdepends=('fish: Option to option fish shell'
source=("$pkgname::git+https://git.stefanwimmer128.eu/stefanwimmer128/zellij-selector.git#tag=v$pkgver")
sha256sums=('SKIP')
-build() {
- cd "$pkgname"
-
- make
-}
-
check() {
cd "$pkgname"