summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD4
-rw-r--r--redundant.patch21
3 files changed, 7 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10f871bb1097..68c9714d0774 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = zeroc-ice-php
pkgdesc = PHP bindings for Ice RPC framework
- pkgver = 3.7.7
+ pkgver = 3.7.8
pkgrel = 1
url = https://zeroc.com
arch = i686
arch = x86_64
license = GPL
license = custom:Ice license
- makedepends = zeroc-ice=3.7.7
+ makedepends = zeroc-ice=3.7.8
makedepends = php
- depends = zeroc-ice=3.7.7
+ depends = zeroc-ice=3.7.8
depends = php
- source = ice-3.7.7.tar.gz::https://github.com/zeroc-ice/ice/archive/v3.7.7.tar.gz
- sha256sums = 3aef143a44a664f3101cfe02fd13356c739c922e353ef0c186895b5843a312ae
+ source = ice-3.7.8.tar.gz::https://github.com/zeroc-ice/ice/archive/v3.7.8.tar.gz
+ sha256sums = f2ab6b151ab0418fab30bafc2524d9ba4c767a1014f102df88d735fc775f9824
pkgname = zeroc-ice-php
diff --git a/PKGBUILD b/PKGBUILD
index 0ebef67ca260..2f463cd87352 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Arisu <arisuuwu32@gmail.com>
pkgname="zeroc-ice-php"
-pkgver=3.7.7
+pkgver=3.7.8
pkgrel=1
pkgdesc="PHP bindings for Ice RPC framework"
arch=("i686" "x86_64")
@@ -16,7 +16,7 @@ depends=("zeroc-ice=$pkgver" "php")
source=("ice-${pkgver}.tar.gz::https://github.com/zeroc-ice/ice/archive/v${pkgver}.tar.gz")
-sha256sums=('3aef143a44a664f3101cfe02fd13356c739c922e353ef0c186895b5843a312ae')
+sha256sums=('f2ab6b151ab0418fab30bafc2524d9ba4c767a1014f102df88d735fc775f9824')
make_args=(
"OPTIMIZE=yes"
diff --git a/redundant.patch b/redundant.patch
deleted file mode 100644
index 3f37ee4700d6..000000000000
--- a/redundant.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From f542ad5eb07d9f129d7160d9e46ab07bda2afa7a Mon Sep 17 00:00:00 2001
-From: Jose <jose@zeroc.com>
-Date: Sat, 4 Dec 2021 09:54:36 +0100
-Subject: [PATCH] Ignore redundant declarations with PHP > 8
-
----
- php/src/php/Config.h | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/php/src/php/Config.h b/php/src/php/Config.h
-index c5d9db61d57..3f308d45ce7 100644
---- a/php/src/php/Config.h
-+++ b/php/src/php/Config.h
-@@ -50,6 +50,7 @@ extern "C"
-
- #if defined(__GNUC__) && ((__GNUC__ >= 8))
- # pragma GCC diagnostic ignored "-Wignored-qualifiers"
-+# pragma GCC diagnostic ignored "-Wredundant-decls"
- #endif
-
- //