summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2206f03b8c85..980190d54626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
pkgbase = zesarux-git
pkgdesc = A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support. WARNING. This is a Snapshot version and not a stable one. Some features may not work or suffer random crashes or abnormal CPU use
- pkgver = v6.1.r1001.g725c0a8
+ pkgver = 9.2.r184.g26813f5e
pkgrel = 1
url = https://github.com/chernandezba/zesarux
install = zesarux.install
arch = i686
arch = x86_64
license = GPL3
- optdepends = pulseaudio: for support Pulseaudio
+ depends = libxxf86vm
+ depends = aalib
+ depends = libcaca
+ depends = alsa-lib
+ optdepends = libpulse: for support Pulseaudio
optdepends = openssl: for enable SSL functions
optdepends = sdl: for support sdl video and audio output
conflicts = zesarux
diff --git a/PKGBUILD b/PKGBUILD
index df98896b6320..203d3d6c853d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
+# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=zesarux-git
-
-pkgver=v6.1.r1001.g725c0a8
-_ver=6.1
+pkgver=9.2.r184.g26813f5e
+_ver=9.3
pkgrel=1
pkgdesc="A Zx80/Zx81/Z88, Zx Spectrum 16/48/128/+2/+2A and ZX-Uno emulator with ULAPlus support. WARNING. This is a Snapshot version and not a stable one. Some features may not work or suffer random crashes or abnormal CPU use"
arch=('i686' 'x86_64')
url="https://github.com/chernandezba/zesarux"
license=('GPL3')
conflicts=('zesarux')
-depens=('lesstif')
-optdepends=('pulseaudio: for support Pulseaudio'
+depends=('libxxf86vm' 'aalib' 'libcaca' 'alsa-lib')
+optdepends=('libpulse: for support Pulseaudio'
'openssl: for enable SSL functions'
'sdl: for support sdl video and audio output')
@@ -21,15 +21,12 @@ install="zesarux.install"
pkgver() {
cd "$srcdir/zesarux-code"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/zesarux-code/src"
- ./configure --prefix /usr --disable-caca --disable-aa
+ ./configure --prefix /usr --enable-memptr --enable-visualmem --enable-cpustats
sed -i 's/tar -C/#tar -C/g' Makefile
make bintargz
}