summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 13 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c9d8d70e1d5..b79aa922a7a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zettlr
pkgdesc = A markdown editor for writing academic texts and taking notes
pkgver = 1.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.zettlr.com
arch = x86_64
license = GPL
@@ -19,26 +19,10 @@ pkgbase = zettlr
source = https://github.com/citation-style-language/locales/archive/cbb45961b815594f35c36da7e78154feb5647823.zip
source = https://github.com/citation-style-language/styles/raw/master/chicago-author-date.csl
source = https://github.com/Brli/zetter-zh-TW/raw/master/zh-TW.json
- source = https://translate.zettlr.com/download/de-DE.json
- source = https://translate.zettlr.com/download/en-GB.json
- source = https://translate.zettlr.com/download/en-US.json
- source = https://translate.zettlr.com/download/fr-FR.json
- source = https://translate.zettlr.com/download/ja-JP.json
- source = https://translate.zettlr.com/download/zh-CN.json
- source = https://translate.zettlr.com/download/es-ES.json
- source = https://translate.zettlr.com/download/ru-RU.json
sha256sums = SKIP
sha256sums = 8ee8c7e0ea63aacf811fb6f4bdb8f8f32929bf9afdad2f0ffc2f6bfb721d1fd5
sha256sums = 2b7cd6c1c9be4add8c660fb9c6ca54f1b6c3c4f49d6ed9fa39c9f9b10fcca6f4
sha256sums = 81730193afc64908f820020a19bfeda4475c67ada92e8567a39c9313a3d65ff0
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = zettlr
diff --git a/PKGBUILD b/PKGBUILD
index 340d1ff37bb7..7110a7f330a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=zettlr
pkgver=1.8.1
-pkgrel=1
+pkgrel=2
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
@@ -14,51 +14,38 @@ optdepends=('pandoc: For exporting to various format'
'ttf-lato: Display output in a more comfortable way')
_commit=93273f39a0a178f82ad3c8ed64d01faf4224aab1 # 1.8.1^0
_csl_locale_commit=cbb45961b815594f35c36da7e78154feb5647823
-_lang=('de-DE' 'en-GB' 'en-US' 'fr-FR' 'ja-JP' 'zh-CN' 'es-ES' 'ru-RU')
source=(git+https://github.com/Zettlr/Zettlr.git#commit="${_commit}"
# citation style
https://github.com/citation-style-language/locales/archive/"${_csl_locale_commit}.zip"
https://github.com/citation-style-language/styles/raw/master/chicago-author-date.csl
# Chinese(Taiwan) translation
https://github.com/Brli/zetter-zh-TW/raw/master/zh-TW.json)
- # translations
sha256sums=('SKIP'
'8ee8c7e0ea63aacf811fb6f4bdb8f8f32929bf9afdad2f0ffc2f6bfb721d1fd5'
'2b7cd6c1c9be4add8c660fb9c6ca54f1b6c3c4f49d6ed9fa39c9f9b10fcca6f4'
'81730193afc64908f820020a19bfeda4475c67ada92e8567a39c9313a3d65ff0')
-for _l in ${_lang[@]}; do
- source+=(https://translate.zettlr.com/download/${_l}.json)
- sha256sums+=('SKIP')
-done
prepare() {
cd "${srcdir}/Zettlr"
# pandoc citeproc argument deprecation
sed 's,--filter pandoc-citeproc,--citeproc,' -i source/main/modules/export/run-pandoc.js
-
+
# LaTeX Error: Environment CSLReferences undefined.
sed 's,cslreferences,CSLReferences,' -i source/main/assets/export.tex
# We don't build electron and friends, and don't depends on postinstall script
sed '/^\s*\"electron-notarize.*$/d;/^\s*\"electron-builder.*$/d;/postinstall/d' -i package.json
- # npm/yarn failed with the ^head...
- sed 's/\^10.1.5/10.1.5/' -i package.json
-
- # lang:refresh from package.json
- for _l in ${_lang[@]}; do
- cp "${srcdir}/${_l}.json" source/common/lang/
- done
+ sed 's,beta.53,beta.54,' -i package.json
- # manually add community translation
+ # Manually add community translation
cp "${srcdir}/zh-TW.json" source/common/lang/
# csl:refresh from package.json
cp $(find "${srcdir}/locales-${_csl_locale_commit}/" -name "*.xml") source/app/service-providers/assets/csl-locales/
cp "${srcdir}/locales-${_csl_locale_commit}/locales.json" source/app/service-providers/assets/csl-locales/
cp "${srcdir}/chicago-author-date.csl" source/app/service-providers/assets/csl-styles/
-
}
build() {
@@ -70,12 +57,15 @@ build() {
--ignore-scripts
yarn reveal:build
- cd "${srcdir}/Zettlr/source"
- yarn install --pure-lockfile --cache-folder "${srcdir}/cache"
+ rm -rf node_modules/electron
+ yarn add -D electron@10.1.5 --cache-folder "${srcdir}/cache" --link-folder "${srcdir}/link"
cd "${srcdir}/Zettlr"
- # failed without deb or rpm anyway, we just want the outcome
- node node_modules/.bin/electron-forge package || true
+ node node_modules/.bin/electron-forge package
+
+ # Remove fonts
+ cd "${srcdir}/Zettlr/.webpack"
+ find . -type d -name "fonts" -exec rm -rf {} +
}
# check() {
@@ -100,7 +90,7 @@ package() {
# copy the generated electron project
cp -r --no-preserve=ownership --preserve=mode ./* "${pkgdir}/${_destdir}/"
-
+
# symlink to /usr/bin
install -dm755 "${pkgdir}/usr/bin"
ln -sf "/${_destdir}/Zettlr" "${pkgdir}/usr/bin/zettlr"