summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 973c31c7c17b..95fde14d6b91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zettlr
pkgdesc = A markdown editor for writing academic texts and taking notes
- pkgver = 1.8.7
- pkgrel = 2
+ pkgver = 1.8.8
+ pkgrel = 1
url = https://www.zettlr.com
install = install
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = zettlr
optdepends = texlive-bin: For Latex support
optdepends = ttf-lato: Display output in a more comfortable way
options = !strip
- source = zettlr-1.8.7.tar.gz::https://github.com/Zettlr/Zettlr/archive/v1.8.7.tar.gz
- source = locales-2-1.8.7.zip::https://github.com/citation-style-language/locales/archive/ecb8e70233e9a68e8b1dda4586061be8f8611a38.zip
- source = chicago-author-date-1.8.7-2.csl::https://github.com/citation-style-language/styles/raw/a7899732910f5e69aae7799bf4e61505716c211b/chicago-author-date.csl
- sha256sums = 7b0d7dee7a6f95e8e282ad2cf057c0242056d8a02366eb3bb80d5f010a823fe6
+ source = zettlr-1.8.8.tar.gz::https://github.com/Zettlr/Zettlr/archive/v1.8.8.tar.gz
+ source = locales-1-1.8.8.zip::https://github.com/citation-style-language/locales/archive/ecb8e70233e9a68e8b1dda4586061be8f8611a38.zip
+ source = chicago-author-date-1.8.8-1.csl::https://github.com/citation-style-language/styles/raw/a7899732910f5e69aae7799bf4e61505716c211b/chicago-author-date.csl
+ sha256sums = cce11cca98358dbe48a7f42bafaa789dba77add711b9e37f155ee8c956085938
sha256sums = 24503a6cd5b3651a7003353811ae82d3ed707ec8ff932d341668c2ad377434b6
sha256sums = 2b7cd6c1c9be4add8c660fb9c6ca54f1b6c3c4f49d6ed9fa39c9f9b10fcca6f4
diff --git a/PKGBUILD b/PKGBUILD
index 8edce5ec0df9..efc964826f89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=zettlr
-pkgver=1.8.7
-pkgrel=2
+pkgver=1.8.8
+pkgrel=1
pkgdesc="A markdown editor for writing academic texts and taking notes"
arch=('x86_64')
url='https://www.zettlr.com'
license=('GPL' 'custom') # Noted that the icon and name are copyrighted
-_electron=electron
-depends=($_electron)
+depends=(electron)
makedepends=(pandoc git yarn)
optdepends=('pandoc: For exporting to various format'
'texlive-bin: For Latex support'
@@ -22,7 +21,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/Zettlr/Zettlr/archive/v$pkg
# citation style
"locales-$pkgrel-$pkgver.zip::https://github.com/citation-style-language/locales/archive/$_csl_locale_commit.zip"
"chicago-author-date-$pkgver-$pkgrel.csl::https://github.com/citation-style-language/styles/raw/$_csl_style_commit/chicago-author-date.csl")
-sha256sums=('7b0d7dee7a6f95e8e282ad2cf057c0242056d8a02366eb3bb80d5f010a823fe6'
+sha256sums=('cce11cca98358dbe48a7f42bafaa789dba77add711b9e37f155ee8c956085938'
'24503a6cd5b3651a7003353811ae82d3ed707ec8ff932d341668c2ad377434b6'
'2b7cd6c1c9be4add8c660fb9c6ca54f1b6c3c4f49d6ed9fa39c9f9b10fcca6f4')
@@ -40,7 +39,7 @@ prepare() {
}
build() {
- local _electronVersion=$($_electron --version | sed -e 's/^v//')
+ local _electronVersion=$(electron --version | sed -e 's/^v//')
cd "Zettlr-$pkgver"
local NODE_ENV=''
yarn install --cache-folder "$srcdir/cache" \
@@ -86,7 +85,7 @@ package() {
# Install start script to /usr/bin
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh
-exec $_electron /${_destdir} "\$@"
+exec electron /${_destdir} "\$@"
END
# install icons of various sizes to hi-color theme