summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03dbbd4b955e..1d598d8fe90b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = zfec
- pkgdesc = A fast erasure codec which can be used with the command-line, C, Python, or Haskell
+ pkgdesc = Fast erasure coding tool
pkgver = 1.5.7.2
- pkgrel = 1
- url = https://pypi.python.org/pypi/zfec
- arch = any
+ pkgrel = 2
+ url = https://github.com/tahoe-lafs/zfec
+ arch = x86_64
license = GPL
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools
depends = python
- source = https://files.pythonhosted.org/packages/source/z/zfec/zfec-1.5.7.2.tar.gz
+ source = python-zfec-1.5.7.2.tar.gz::https://files.pythonhosted.org/packages/source/z/zfec/zfec-1.5.7.2.tar.gz
sha256sums = 4ee519be0dcc7da2e88482bcfc0bf977a425e1d7e8278cf5bbbb8d00f8a2afb6
pkgname = python-zfec
diff --git a/PKGBUILD b/PKGBUILD
index ad496e2dedbf..4247c1141c12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
-# Maintainer: Nicolas Pouillard <nicolas.pouillard@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=zfec
pkgname=python-zfec
pkgver=1.5.7.2
-pkgrel=1
-pkgdesc="A fast erasure codec which can be used with the command-line, C, Python, or Haskell"
-arch=('any')
-url='https://pypi.python.org/pypi/zfec'
+pkgrel=2
+pkgdesc="Fast erasure coding tool"
+arch=('x86_64')
+url='https://github.com/tahoe-lafs/zfec'
license=('GPL')
depends=('python')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/z/zfec/zfec-${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/z/zfec/zfec-$pkgver.tar.gz")
sha256sums=('4ee519be0dcc7da2e88482bcfc0bf977a425e1d7e8278cf5bbbb8d00f8a2afb6')
+prepare() {
+ cd "zfec-$pkgver"
+ # deleting SOURCES.txt and excluding tests isn't good enough
+ rm -rf zfec/test
+}
+
build() {
- cd "zfec-$pkgver"
- python -m build --wheel --no-isolation
+ cd "zfec-$pkgver"
+ python -m build --wheel --no-isolation
}
package_python-zfec() {
- cd "zfec-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "zfec-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
}