summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf4f93b25c0..8d763db322ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,17 +5,12 @@ pkgbase = zfec
url = https://pypi.python.org/pypi/zfec
arch = any
license = GPL
- makedepends = python2-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
+ depends = python
source = https://files.pythonhosted.org/packages/source/z/zfec/zfec-1.5.5.tar.gz
sha256sums = 6033b2f3cc3edacf3f7eeed5f258c1ebf8a1d7e5e35b623db352512ce564e5ca
-pkgname = python2-zfec
- depends = python2-pyutil
- conflicts = python-zfec
- replaces = zfec
-
pkgname = python-zfec
- depends = python-pyutil
- conflicts = python2-zfec
-
diff --git a/PKGBUILD b/PKGBUILD
index a30983caa7f7..55c44f88cbc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
# Contributor: Peter Simons <simons@cryp.to>
pkgbase=zfec
-pkgname=('python2-zfec' 'python-zfec')
+pkgname=python-zfec
pkgver=1.5.5
pkgrel=1
pkgdesc="A fast erasure codec which can be used with the command-line, C, Python, or Haskell"
arch=('any')
url='https://pypi.python.org/pypi/zfec'
license=('GPL')
-makedepends=('python2-setuptools' 'python-setuptools')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/z/zfec/zfec-${pkgver}.tar.gz")
sha256sums=('6033b2f3cc3edacf3f7eeed5f258c1ebf8a1d7e5e35b623db352512ce564e5ca')
-package_python2-zfec() {
- depends=('python2-pyutil')
- replaces=('zfec')
- conflicts=('python-zfec')
-
+build() {
cd "zfec-$pkgver"
- python2 setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ python -m build --wheel --no-isolation
}
package_python-zfec() {
- depends=('python-pyutil')
- conflicts=('python2-zfec')
-
cd "zfec-$pkgver"
- python setup.py install --root="$pkgdir" --prefix='/usr' --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}