summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD60
2 files changed, 38 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27caadc399c..b53b06de394e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
pkgbase = zfs-dkms-git
- pkgver = 0.7.0_r1575_g93491c4bb
- pkgrel = 1
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ pkgver = 2018.11.09.r4825.g0500bfd0b
+ pkgrel = 2
url = http://zfsonlinux.org/
- arch = i686
arch = x86_64
+ groups = archzfs-dkms-git
license = CDDL
makedepends = git
- source = git+https://github.com/zfsonlinux/zfs.git
- sha256sums = SKIP
-
-pkgname = zfs-dkms-git
- pkgdesc = Kernel modules for the Zettabyte File System. (Git version)
- depends = zfs-utils-git=0.7.0_r1575_g93491c4bb-1
- depends = dkms
+ depends = zfs-utils-git=2018.11.09.r4825.g0500bfd0b
depends = lsb-release
+ depends = dkms
provides = zfs
+ provides = zfs-headers
provides = spl
- conflicts = zfs-git
- conflicts = zfs-lts
- conflicts = zfs-dkms
- conflicts = spl-dkms-git
+ provides = spl-headers
+ conflicts = zfs
+ conflicts = zfs-headers
+ conflicts = spl
+ conflicts = spl-headers
replaces = spl-dkms-git
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=0500bfd0b9f1393af5bae274551147c5b31e7ccc
+ sha256sums = SKIP
+
+pkgname = zfs-dkms-git
diff --git a/PKGBUILD b/PKGBUILD
index ef05e7d20792..3d34dc927b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,39 @@
# Maintainer: Jan Houben <jan@nexttrex.de>
-# Contributor: Iacopo Isimbaldi <isiachi@rhye.it>
-
-pkgbase="zfs-dkms-git"
+# Contributor: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
pkgname="zfs-dkms-git"
-pkgver=0.7.0_r1575_g93491c4bb
-pkgrel=1
-license=('CDDL')
+_commit='0500bfd0b9f1393af5bae274551147c5b31e7ccc'
+pkgdesc="Kernel modules for the Zettabyte File System."
+
+pkgver=2018.11.09.r4825.g0500bfd0b
+pkgrel=2
makedepends=("git")
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/zfs"
- git describe --match "zfs-*" --long --tags | sed -e 's|zfs-||' -e 's|-\([0-9]*-g\)|-r\1|' -e 's|[-: ]|_|g'
-}
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}")
+sha256sums=("SKIP")
+license=("CDDL")
+depends=("zfs-utils-git=${pkgver}" "lsb-release" "dkms")
+provides=("zfs" "zfs-headers" "spl" "spl-headers")
+groups=("archzfs-dkms-git")
+conflicts=("zfs" "zfs-headers" "spl" "spl-headers")
+replaces=("spl-dkms-git")
build() {
cd "${srcdir}/zfs"
./autogen.sh
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --sbindir=/usr/bin \
- --with-mounthelperdir=/usr/bin \
- --libdir=/usr/lib \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --with-udevdir=/usr/lib/udev \
- --libexecdir=/usr/lib/zfs \
- --with-config=user \
- --enable-systemd
- make
}
package() {
- pkgdesc="Kernel modules for the Zettabyte File System. (Git version)"
- depends=("zfs-utils-git=${pkgver}-${pkgrel}" "dkms" "lsb-release")
- provides=("zfs" "spl")
- conflicts=("zfs-git" "zfs-lts" "zfs-dkms" "spl-dkms-git")
- replaces=("spl-dkms-git")
-
- dkmsdir="${pkgdir}/usr/src/zfs-${pkgver%%_*}"
+ dkmsdir="${pkgdir}/usr/src/zfs-git"
install -d "${dkmsdir}"
cp -a ${srcdir}/zfs/. ${dkmsdir}
-
cd "${dkmsdir}"
- make clean
- make distclean
find . -name ".git*" -print0 | xargs -0 rm -fr --
- scripts/dkms.mkconf -v ${pkgver%%_*} -f dkms.conf -n zfs
+ scripts/dkms.mkconf -v git -f dkms.conf -n zfs
chmod g-w,o-w -R .
}