summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bffc2771c36b..8d445d338ff7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.9.4.17.10.1
+ pkgver = 0.7.9.4.17.11.1
pkgrel = 2
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.17.10-1
+ makedepends = linux-headers=4.17.11-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.9
- depends = linux=4.17.10-1
+ depends = linux=4.17.11-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz
source = upstream-ac09630-Fix-zpl_mount-deadlock.patch
sha256sums = f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a
diff --git a/PKGBUILD b/PKGBUILD
index b13420a1cbb7..b9fa416eb85a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,15 +19,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.9.4.17.10.1
+pkgver=0.7.9.4.17.11.1
pkgrel=2
-makedepends=("linux-headers=4.17.10-1" "spl-linux-headers")
+makedepends=("linux-headers=4.17.11-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz" "upstream-ac09630-Fix-zpl_mount-deadlock.patch")
sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a" "1799f6f7b2a60a23b66106c9470414628398f6bfc10da3d0f41c548bba6130e8")
license=("CDDL")
-depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.17.10-1")
+depends=("kmod" 'spl-linux' "zfs-utils-common=0.7.9" "linux=4.17.11-1")
prepare() {
cd "${srcdir}/zfs-0.7.9"
patch -Np1 -i ${srcdir}/upstream-ac09630-Fix-zpl_mount-deadlock.patch
@@ -39,8 +39,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.17.10-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.17.10-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.17.11-arch1/build \
+ --with-linux-obj=/usr/lib/modules/4.17.11-arch1/build
make
}
@@ -66,5 +66,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.17.10-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.17.11-arch1/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 13a6b45c314f..ad704cf352de 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.17.10-1-ARCH
+ depmod -a 4.17.11-arch1
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'