summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--zfs.install27
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40adbe397178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Apr 21 08:44:29 UTC 2016
+pkgbase = zfs-linux
+ pkgdesc = Kernel modules for the Zettabyte File System.
+ pkgver = 0.6.5.6_4.5.1_1
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ install = zfs.install
+ arch = x86_64
+ groups = archzfs-linux
+ license = CDDL
+ depends = kmod
+ depends = spl-linux
+ depends = zfs-utils-linux
+ depends = linux>=4.5.1
+ depends = linux<4.6
+ depends = linux-headers>=4.5.1
+ depends = linux-headers<4.6
+ provides = zfs-linux
+ source = http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/zfs-0.6.5.6.tar.gz
+ sha256sums = c349d46d86b4f61cd53a0891acad916cfc3f0d6754127db7f60a0bd98185aeff
+
+pkgname = zfs-linux
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df2e29bbe7d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+*.sig
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab3caaf661e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux packages will only work with the default package! To have a single PKGBUILD target many kernels
+# would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgname="zfs-linux"
+pkgver=0.6.5.6_4.5.1_1
+pkgrel=1
+pkgdesc="Kernel modules for the Zettabyte File System."
+depends=("kmod" "spl-linux" "zfs-utils-linux"
+ "linux>=4.5.1" "linux<4.6"
+ "linux-headers>=4.5.1" "linux-headers<4.6")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("http://archive.zfsonlinux.org/downloads/zfsonlinux/zfs/zfs-0.6.5.6.tar.gz")
+sha256sums=("c349d46d86b4f61cd53a0891acad916cfc3f0d6754127db7f60a0bd98185aeff")
+groups=("archzfs-linux")
+license=("CDDL")
+install=zfs.install
+provides=("zfs-linux")
+
+
+build() {
+ cd "${srcdir}/zfs-0.6.5.6"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
+ --datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
+ --libexecdir=/usr/lib/zfs-0.6.5.6 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.5.1-1-ARCH/build
+ make
+}
+
+package() {
+ cd "${srcdir}/zfs-0.6.5.6"
+ make DESTDIR="${pkgdir}" install
+ cp -r "${pkgdir}"/{lib,usr}
+ rm -r "${pkgdir}"/lib
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.5.1-1-ARCH/Module.symvers
+}
diff --git a/zfs.install b/zfs.install
new file mode 100644
index 000000000000..814ff307eb10
--- /dev/null
+++ b/zfs.install
@@ -0,0 +1,27 @@
+post_install() {
+ check_initramfs
+}
+
+post_remove() {
+ check_initramfs 'remove'
+}
+
+post_upgrade() {
+ check_initramfs
+}
+
+check_initramfs() {
+ echo ">>> Updating ZFS module dependencies"
+ depmod 4.5.1-1-ARCH
+ MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
+ if [[ ${MK_CONF} == '0' ]]; then
+ if [[ $1 == 'remove' ]]; then
+ echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'
+ echo '>>> list in mkinitcpio.conf! You will need to remove "zfs" from the '
+ echo '>>> "hooks" list and then regenerate the initial ramdisk.'
+ else
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux
+ fi
+ fi
+}