summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
-rw-r--r--zfs.install2
3 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 642c6d234f80..1768376f7f88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = zfs-linux
- pkgver = 0.7.8.4.16.7.1
+ pkgver = 0.7.9.4.16.8.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.16.7-1
+ makedepends = linux-headers=4.16.8-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
- depends = zfs-utils-common=0.7.8
- depends = linux=4.16.7-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/zfs-0.7.8.tar.gz
- sha256sums = 70ba0edd72914d4bfc9a9426cf26725e955a9509acbddb6902efb9eebb35f150
+ depends = zfs-utils-common=0.7.9
+ depends = linux=4.16.8-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz
+ sha256sums = f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a
pkgname = zfs-linux
pkgdesc = Kernel modules for the Zettabyte File System.
diff --git a/PKGBUILD b/PKGBUILD
index fe1840048193..b5158b6b1bb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,24 +17,24 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.8.4.16.7.1
+pkgver=0.7.9.4.16.8.1
pkgrel=1
-makedepends=("linux-headers=4.16.7-1" "spl-linux-headers")
+makedepends=("linux-headers=4.16.8-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.8/zfs-0.7.8.tar.gz")
-sha256sums=("70ba0edd72914d4bfc9a9426cf26725e955a9509acbddb6902efb9eebb35f150")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.9/zfs-0.7.9.tar.gz")
+sha256sums=("f50ca2441c6abde4fe6b9f54d5583a45813031d6bb72b0011b00fc2683cd9f7a")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.8" "linux=4.16.7-1")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.9" "linux=4.16.8-1")
build() {
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.8 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.16.7-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.16.7-1-ARCH/build
+ --libexecdir=/usr/lib/zfs-0.7.9 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.16.8-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.16.8-1-ARCH/build
make
}
@@ -45,7 +45,7 @@ package_zfs-linux() {
groups=("archzfs-linux")
conflicts=('zfs-linux-git')
replaces=("zfs-git")
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,9 +56,9 @@ package_zfs-linux() {
package_zfs-linux-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.8"
+ cd "${srcdir}/zfs-0.7.9"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.7-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.16.8-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 13704e8eb810..332e55f8eaab 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.16.7-1-ARCH
+ depmod -a 4.16.8-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'