summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--zfs.install2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38f442b1fa8d..ce44e5b0b51b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zfs-linux
- pkgver = 0.7.6.4.15.3.2
+ pkgver = 0.7.6.4.15.5.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.15.3-2
+ makedepends = linux-headers=4.15.5-1
makedepends = spl-linux-headers
depends = kmod
depends = spl-linux
depends = zfs-utils-common=0.7.6
- depends = linux=4.15.3-2
+ depends = linux=4.15.5-1
source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz
sha256sums = 1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d
diff --git a/PKGBUILD b/PKGBUILD
index bd1110e7f265..472d0685efc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux"
pkgname=("zfs-linux" "zfs-linux-headers")
-pkgver=0.7.6.4.15.3.2
+pkgver=0.7.6.4.15.5.1
pkgrel=1
-makedepends=("linux-headers=4.15.3-2" "spl-linux-headers")
+makedepends=("linux-headers=4.15.5-1" "spl-linux-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.6/zfs-0.7.6.tar.gz")
sha256sums=("1687f4041a990e35caccc4751aa736e8e55123b81d5f5a35b11916d9e580c23d")
license=("CDDL")
-depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.3-2")
+depends=("kmod" "spl-linux" "zfs-utils-common=0.7.6" "linux=4.15.5-1")
build() {
cd "${srcdir}/zfs-0.7.6"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.3-2-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.15.3-2-ARCH/build
+ --with-linux=/usr/lib/modules/4.15.5-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.15.5-1-ARCH/build
make
}
@@ -60,5 +60,5 @@ package_zfs-linux-headers() {
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.3-2-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.5-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 33f93a79218f..bef605ba2e39 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.15.3-2-ARCH
+ depmod -a 4.15.5-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'