summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch19
3 files changed, 34 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 78c67dd3e031..4d1a5ceb7a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = zfs-linux-git
- pkgver = 2018.12.18.r4869.g00f198de6_4.19.12.arch1.1
+ pkgver = 2018.12.26.r4871.g06f3fc2a4_4.20.arch1.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.19.12.arch1-1
+ makedepends = linux-headers=4.20.arch1-1
makedepends = git
depends = kmod
- depends = zfs-utils-git=2018.12.18.r4869.g00f198de6
- depends = linux=4.19.12.arch1-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=00f198de6b6ac663926bff2666d956a61cea85db
+ depends = zfs-utils-git=2018.12.26.r4871.g06f3fc2a4
+ depends = linux=4.20.arch1-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=06f3fc2a4b097545259935d54634c5c6f49ed20f
+ source = upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch
sha256sums = SKIP
+ sha256sums = 6f27c3dae57c424e06aec31df6c1e1a821e547aa4e933f2f9b894b5e6762b52d
pkgname = zfs-linux-git
pkgdesc = Kernel modules for the Zettabyte File System.
diff --git a/PKGBUILD b/PKGBUILD
index a582d584db17..5ba2b1c0c5ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,18 +17,20 @@
#
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-_commit='00f198de6b6ac663926bff2666d956a61cea85db'
-_zfsver="2018.12.18.r4869.g00f198de6"
-_kernelver="4.19.12.arch1-1"
-_extramodules="${_kernelver/.arch/-arch}-ARCH"
+_commit='06f3fc2a4b097545259935d54634c5c6f49ed20f'
+_zfsver="2018.12.26.r4871.g06f3fc2a4"
+_kernelver="4.20.arch1-1"
+_extramodules="4.20.0-arch1-1-ARCH"
pkgver="${_zfsver}_$(echo ${_kernelver} | sed s/-/./g)"
pkgrel=1
makedepends=("linux-headers=${_kernelver}" "git")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}")
-sha256sums=("SKIP")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=${_commit}"
+ "upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch")
+sha256sums=("SKIP"
+ "6f27c3dae57c424e06aec31df6c1e1a821e547aa4e933f2f9b894b5e6762b52d")
license=("CDDL")
depends=("kmod" "zfs-utils-git=${_zfsver}" "linux=${_kernelver}")
diff --git a/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch b/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch
new file mode 100644
index 000000000000..e36752293987
--- /dev/null
+++ b/upstream-4f981f6-additional-fixes-for-current_kernel_time-in-4.20.patch
@@ -0,0 +1,19 @@
+diff --git a/include/zpios-ctl.h b/include/zpios-ctl.h
+index f17f1153260..068c9eaf173 100644
+--- a/include/zpios-ctl.h
++++ b/include/zpios-ctl.h
+@@ -181,9 +181,12 @@ zpios_timespec_t
+ zpios_timespec_now(void)
+ {
+ zpios_timespec_t zts_now;
+- struct timespec ts_now;
++ #if defined(HAVE_INODE_TIMESPEC64_TIMES)
++ inode_timespec_t ts_now = current_kernel_time64();
++ #else
++ inode_timespec_t ts_now = current_kernel_time();
++ #endif
+
+- ts_now = current_kernel_time();
+ zts_now.ts_sec = ts_now.tv_sec;
+ zts_now.ts_nsec = ts_now.tv_nsec;
+