summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
-rw-r--r--zfs.install2
3 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba4327ccca16..d0ee445bc76a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = zfs-linux-git
- pkgver = 2018.03.06.r3353.639b18944.4.15.7.1
+ pkgver = 2018.03.12.r3366.83362e8e6.4.15.8.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-headers=4.15.7-1
+ makedepends = linux-headers=4.15.8-1
makedepends = git
makedepends = spl-linux-git-headers
depends = kmod
depends = spl-linux-git
- depends = zfs-utils-common-git=2018.03.06.r3353.639b18944
- depends = linux=4.15.7-1
- source = git+https://github.com/zfsonlinux/zfs.git#commit=639b18944a6a3483c02039621c02dac08a954a90
+ depends = zfs-utils-common-git=2018.03.12.r3366.83362e8e6
+ depends = linux=4.15.8-1
+ source = git+https://github.com/zfsonlinux/zfs.git#commit=83362e8e676a3ffae6b3b21f350f9b999a068605
sha256sums = SKIP
pkgname = zfs-linux-git
@@ -33,6 +33,8 @@ pkgname = zfs-linux-git-headers
conflicts = zfs-linux-headers
conflicts = zfs-linux-threadripper-headers
conflicts = zfs-linux-threadripper-git-headers
+ conflicts = zfs-linux-threadripper-vfio-headers
+ conflicts = zfs-linux-threadripper-vfio-git-headers
conflicts = zfs-linux-vfio-headers
conflicts = zfs-linux-vfio-git-headers
conflicts = zfs-linux-zen-headers
diff --git a/PKGBUILD b/PKGBUILD
index 5fa8dd391d6d..de8608aa5bde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,15 +17,15 @@
pkgbase="zfs-linux-git"
pkgname=("zfs-linux-git" "zfs-linux-git-headers")
-pkgver=2018.03.06.r3353.639b18944.4.15.7.1
+pkgver=2018.03.12.r3366.83362e8e6.4.15.8.1
pkgrel=1
-makedepends=("linux-headers=4.15.7-1" "git" "spl-linux-git-headers")
+makedepends=("linux-headers=4.15.8-1" "git" "spl-linux-git-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("git+https://github.com/zfsonlinux/zfs.git#commit=639b18944a6a3483c02039621c02dac08a954a90")
+source=("git+https://github.com/zfsonlinux/zfs.git#commit=83362e8e676a3ffae6b3b21f350f9b999a068605")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2018.03.06.r3353.639b18944" "linux=4.15.7-1")
+depends=("kmod" "spl-linux-git" "zfs-utils-common-git=2018.03.12.r3366.83362e8e6" "linux=4.15.8-1")
build() {
cd "${srcdir}/zfs"
@@ -33,8 +33,8 @@ build() {
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
--libexecdir=/usr/lib/zfs-0.7.6 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.15.7-1-ARCH/build \
- --with-linux-obj=/usr/lib/modules/4.15.7-1-ARCH/build
+ --with-linux=/usr/lib/modules/4.15.8-1-ARCH/build \
+ --with-linux-obj=/usr/lib/modules/4.15.8-1-ARCH/build
make
}
@@ -55,10 +55,10 @@ package_zfs-linux-git() {
package_zfs-linux-git-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
- conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
+ conflicts=('zfs-archiso-linux-headers' 'zfs-archiso-linux-git-headers' 'zfs-linux-hardened-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-threadripper-headers' 'zfs-linux-threadripper-git-headers' 'zfs-linux-threadripper-vfio-headers' 'zfs-linux-threadripper-vfio-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
cd "${srcdir}/zfs"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.7-1-ARCH/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.15.8-1-ARCH/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 07242204ff63..698ce1951ec4 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.15.7-1-ARCH
+ depmod -a 4.15.8-1-ARCH
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'