summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--zfs.install2
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f96bbaa96e16..43f8bb098f60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Dec 18 22:18:04 UTC 2017
+# Fri Dec 22 00:59:03 UTC 2017
pkgbase = zfs-linux-hardened
- pkgver = 0.7.4_4.14.7.a.1
+ pkgver = 0.7.5_4.14.8.b.1
pkgrel = 1
url = http://zfsonlinux.org/
arch = x86_64
license = CDDL
- makedepends = linux-hardened-headers=4.14.7.a-1
+ makedepends = linux-hardened-headers=4.14.8.b-1
makedepends = spl-linux-hardened-headers
depends = kmod
depends = spl-linux-hardened
- depends = zfs-utils-common=0.7.4
- depends = linux-hardened=4.14.7.a-1
- source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/zfs-0.7.4.tar.gz
+ depends = zfs-utils-common=0.7.5
+ depends = linux-hardened=4.14.8.b-1
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz
sha256sums = SKIP
pkgname = zfs-linux-hardened
diff --git a/PKGBUILD b/PKGBUILD
index f77bafee8621..31c2a67af63e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,24 +18,24 @@
pkgbase="zfs-linux-hardened"
pkgname=("zfs-linux-hardened" "zfs-linux-hardened-headers")
-pkgver=0.7.4_4.14.7.a.1
+pkgver=0.7.5_4.14.8.b.1
pkgrel=1
-makedepends=("linux-hardened-headers=4.14.7.a-1" "spl-linux-hardened-headers")
+makedepends=("linux-hardened-headers=4.14.8.b-1" "spl-linux-hardened-headers")
arch=("x86_64")
url="http://zfsonlinux.org/"
-source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/zfs-0.7.4.tar.gz")
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.5/zfs-0.7.5.tar.gz")
sha256sums=("SKIP")
license=("CDDL")
-depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.4" "linux-hardened=4.14.7.a-1")
+depends=("kmod" "spl-linux-hardened" "zfs-utils-common=0.7.5" "linux-hardened=4.14.8.b-1")
build() {
- cd "${srcdir}/zfs-0.7.4"
+ cd "${srcdir}/zfs-0.7.5"
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --sbindir=/usr/bin --libdir=/usr/lib \
--datadir=/usr/share --includedir=/usr/include --with-udevdir=/lib/udev \
- --libexecdir=/usr/lib/zfs-0.7.4 --with-config=kernel \
- --with-linux=/usr/lib/modules/4.14.7-1-hardened/build \
- --with-linux-obj=/usr/lib/modules/4.14.7-1-hardened/build
+ --libexecdir=/usr/lib/zfs-0.7.5 --with-config=kernel \
+ --with-linux=/usr/lib/modules/4.14.8-1-hardened/build \
+ --with-linux-obj=/usr/lib/modules/4.14.8-1-hardened/build
make
}
@@ -45,7 +45,7 @@ package_zfs-linux-hardened() {
provides=("zfs")
groups=("archzfs-linux-hardened")
conflicts=('zfs-linux-hardened-git')
- cd "${srcdir}/zfs-0.7.4"
+ cd "${srcdir}/zfs-0.7.5"
make DESTDIR="${pkgdir}" install
cp -r "${pkgdir}"/{lib,usr}
rm -r "${pkgdir}"/lib
@@ -56,9 +56,9 @@ package_zfs-linux-hardened() {
package_zfs-linux-hardened-headers() {
pkgdesc="Kernel headers for the Zettabyte File System."
conflicts=('zfs-archiso-linux-headers' 'zfs-linux-hardened-git-headers' 'zfs-linux-lts-headers' 'zfs-linux-lts-git-headers' 'zfs-linux-headers' 'zfs-linux-git-headers' 'zfs-linux-vfio-headers' 'zfs-linux-vfio-git-headers' 'zfs-linux-zen-headers' 'zfs-linux-zen-git-headers' )
- cd "${srcdir}/zfs-0.7.4"
+ cd "${srcdir}/zfs-0.7.5"
make DESTDIR="${pkgdir}" install
rm -r "${pkgdir}/lib"
# Remove reference to ${srcdir}
- sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.7-1-hardened/Module.symvers
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/zfs-*/4.14.8-1-hardened/Module.symvers
}
diff --git a/zfs.install b/zfs.install
index 6f61d26b3b24..15f448942872 100644
--- a/zfs.install
+++ b/zfs.install
@@ -12,7 +12,7 @@ post_upgrade() {
check_initramfs() {
echo ">>> Updating ZFS module dependencies"
- depmod -a 4.14.7-1-hardened
+ depmod -a 4.14.8-1-hardened
MK_CONF=$(grep -v '#' /etc/mkinitcpio.conf | grep zfs >/dev/null; echo $?);
if [[ ${MK_CONF} == '0' && $1 == 'remove' ]]; then
echo '>>> The ZFS packages have been removed, but "zfs" remains in the "hooks"'